MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-ImageSlideshow not showing up.



  • I have been trying to get MMM-ImageSlideshow to show up, this is my code:

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information on how you can configure this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
    	address: "localhost", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out or empty, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	useHttps: false, 		// Support HTTPS or not, default "false" will use HTTP
    	httpsPrivateKey: "", 	// HTTPS private key path, only require when useHttps is true
    	httpsCertificate: "", 	// HTTPS Certificate path, only require when useHttps is true
    
    	language: "fr",
    	timeFormat: 24,
    	units: "metric",
    	// serverOnly:  true/false/"local" ,
    			     // local for armv6l processors, default
    			     //   starts serveronly and then starts chrome browser
    			     // false, default for all  NON-armv6l devices
    			     // true, force serveronly mode, because you want to.. no UI on this device
    
    	modules: [
    		{
    			module: "alert",
    		},
    		//{
    			//module: "updatenotification",
    			//position: "top_bar"
    		//},
        {
            module: 'MMM-ModuleScheduler',
            config: {
                global_schedule: [
                                 {from: '0 6 * * *', to: '10 17 * * *', groupClass: 'daytime_scheduler'},
                                 {from: '37 17 * * *', to: '59 5 * * *', groupClass: 'nighttime_scheduler'},
                 ]
            }
        },
        		{
    			module: "clock",
    			position: "top_left"
    		},
    		//{
    			//module: "compliments",
    			//position: "lower_third"
    		//},
    		{
    			module: "currentweather",
    			position: "top_left",
    			config: {
    				location: "Sainte-Thérèse",
    				locationID: "6138121", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "############",
    				roundTemp: true
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top _left",
    			header: "Weather Forecast",
    			config: {
    				location: "Sainte-Thérèse",
    				locationID: "6138121", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "############",
    				fade: false,
    				roundTemp: true
    			}
    		},
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "Journalde Montreal",
    						url: "https://www.journaldemontreal.com/rss.xml"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true,
    				broadcastNewsFeeds: true,
    				broadcastNewsUpdates: true
    			}
    		},
    		{
    	module: 'MMM-Globe',
    	position: 'middle_center',
    	classes: 'daytime_scheduler',
    	config: {
    		style: 'geoColor',
    		imageSize: 475,
    		ownImagePath:'',
    		updateInterval: 10*60*1000
    	}
    },
    {
    		module: 'MMM-ImageSlideshow',
    	position: "middle_center",
    	classes: 'nighttime_scheduler',
    		config: {
    			imagePaths: ['modules/MMM-ImageSlideshow/Images'],
                    slideshowSpeed: 100,
                    fixedImageWidth: 500,
                    fixedImageHeight: 500,
                    randomizeImageOrder: true,
    		}
    	},
    {
    		module: 'MMM-Todoist',
    		position: 'top_right',	// This can be any of the regions. Best results in left or right regions.
    		header: 'Todo List', // This is optional
    		config: { // See 'Configuration options' for more information.
    			accessToken: '############',
    			maximumEntries: 25,
    			updateInterval: 5*60*1000, // Update every 10 minutes
    			fade: false,      
    			// projects and/or labels is mandatory:
    			projects: [ 2230379200,
    						2229190923,
    						2229190958,
    						2229191069,
    						2229194307,
    						], 
    			labels: [  ], // Tasks for any projects with these labels will be shown.
    			sortType: "dueDateAsc",
    			displayTasksWithinDays: 40,
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    
    

    I tryed removing the ModuleScheduler and the global module and all that but still no image? what am I doing wrong the image folder is modules/MMM-ImageSlideshow/Images


Log in to reply