MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Screencast not showing up on phone



  • Hi,
    I’m very new to the raspberry pi and MagicMirror stuff so please excuse my ignorance. I downloaded the screencast module and its in my module folder. I also added the script to the config/config.js. However when I run my magic mirror there is no option for me to cast to the mirror when I go into youtube. I feel like I might have made a mistake with the configeration part i added to the modules array but it seems to be correct. If anyone could give me some pointers that would be great.
    Thanks!



  • I can’t remember if turning on OpenGL driver was my issue or not with this…
    As long as your config files is correct (it isnt a hard config file I will post mine below)…
    Try opening a terminal window and type sudo raspi-config
    go to “Advanced Options” and then “OpenGL Driver”

    Depending on the hardware you have or what PI model you are using you may have just one option or a couple…
    IF you have multiple options like I have seen … one was FAKE KMS and the other was FULL KMS…
    I had to choose FULL KMS (i think for raspberry pi3)… on my raspberry pi 4 I believe there is only one option…choose it.

    (might want to reboot)… cant remember if needed or makes you.

    Then try again … make sure your device is on the same wifi network as your mirror …
    You should see your mirror name …

    I can’t think of what more there could be … unless your router is blocking the default port?
    You did do npm install in the module directory after cloning it right?

    My config for the module…

    		{
    			module: 'MMM-Screencast',
    			position: 'center', // This position is for a hidden <div> and not the screencast window
    			config: {
    				position: 'center',
    				height: 300,
    				width: 500,
    			}
    		},
    ```</div>

Log in to reply