MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Fuel NSW no data



  • Hi All,

    I am very new to MagicMirror and programming in general and im having trouble getting the MMM-Fuel module to work.
    It just says ‘Loading…’
    I have checked my api with api.nsw and I appear to be getting an error 400

    below is my config module info

    Any ideas where the issue lies???

    Thanks guys

    ![0_1597401702925_fuel config.jpg](Uploading 100%)



  • Seems my pictures are not loading

    here is the config

                },
                {
                        module: "MMM-Fuel",
                        position: "bottom_right",
                        config: {
                                provider: 'nsw',
                                api_key: "xxxxxxxxxx",
                                secret: "xxxxxxxxxx",
                                lat: -33.8478792,
                                lng: 150.7915495,
                                types: ["P95"],
                                max: 5,
                                }
        }
        ]


  • @jimus888 the API has to return 200 (ok) and data. so if u have 400, then there is a problem



  • @sdetweil
    Hi, would the 400 error indicate an issue with the config file that ive uploaded above? or something wrong with the module config files or my api?



  • @jimus888 yes. I assume the API call uses data from your config to make the call, including your key and location.

    you might be able to see that actual url used for the API, by looking in the developers window. open the developers window ctrl-shift-i on the keyboard, then select the console tab and scroll up to see any errors



  • @jimus888 Hi jimus it looks like possibly your config isn’t quite right?

    Just looking at the readme for MMM-Fuel, when using the nsw provider the config notes say

    types 	["diesel"] 	Valid options are diesel, e5.
    

    so your types: [“P95”] entry in your config isn’t going to be any good. I don’t know if that’s giving you the HTTP 400 bad request that you’re seeing. Maybe try changing this value to “diesel” to see if it starts giving you a valid response?



  • Thanks for the help guys. I didn’t know about the developer window but it has shown me a bunch of errors that i’ll have to work on.

    I got the fuel module working by changing the type to [“e5”], thanks Raymond. Once this has been changed the info showed up 🙂


Log in to reply