MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Tasmota in combination with Sonoff basic r2 and mosquito as broker



  • I’m running mosquito as broker on the pi. With MMM-MQTTBridge I can properly send and receive messages from my sonoff switches, e.g. when I manually enable the light with the button on the device I can show an alert on the mirror.

    Now I want to add an interface to the screen to be able to show the status of the switch and toggle it from the mirror. For this purpose I wanted to use MMM-Tasmota, however I’m struggling with the configuration, and now I’m even wondering if this module actually supports the sonoff switches or only the sensors.

    for MMM-MQTTBridge I use this in config:

    mqttServer: "mqtt://:@localhost:1883",
    the format for MMM-Tasmota suggests something like this, is that the correct format?

    host: 'http://localhost:1883',

    In logs I do see this: host: 'http://localhost:1883', but I do not see any messages about subscribing to the topic of my sonoff switch for which I configured:

    devices: [
        {
          	topic: "woonkamer/sonoff-nr1",
    	name: "lamp",
    	showPowerStats: true
        }
    ],
    

    Should I use a different config?

    (I guess an example file on the github page would be useful).



  • After some debugging in with npm start dev and checking the console this pointed me to an error in my config; showPowerStats is a global setting, not per device.

    After that it started at least to the point where it would subscribe to the mqtt topic, however I should have considered the obvious; my mqtt structure is not the default suggestion of tasmota, so the code does not correspond with that. Currently trying to adapt for that.


Log in to reply