MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Awesome-Alexa isn't working



  • Hi everybody!

    Reading both in the GitHub repo and in this forum I got the idea that this module may be kinda obsolete and unsupported but I really like the visual effect and the possibility to have another Alexa device in my house for basically nothing.

    I already tried to install the module following the instructions at https://awesome-alexa.js.org/#/installation?id=step-2-install-module

    And also tried to install it using @sdetweil do-install.sh script.

    Both times I got a lot of errors but the electron rebuild always worked fine in the end.

    I run the config-helper without any issues and correctly update the config.js file with all the necessary tokens.

    I tested my microphone and stereo device (a bluetooth JBL Go) using the audio setup troubleshooting page at https://awesome-alexa.js.org/#/audio-setup

    But when I launch the MagicMirror, even without any error, Alexa is totally unresponsive, can somebody help?

    Using an rpi3 with
    node 14.15.0
    npm 6.14.8



  • @LukeTheWalker what is the device name in the config.js, does it match what u were using in the testing?



  • Maybe I am not understanding the question correctly.

    In the ~/MagicMirror/config/config.js file, in the MMM-awesome-alexa module object there is a parameter named deviceId which I set to the value I found on my amazon console developer, here is the section am referring to:
    config pic.png

    And here is the amazon page from which I picked it
    amazon id.png



  • @LukeTheWalker

    is the mic device set as the default?



  • It should

    B649C759-5182-4C50-A931-599AD378CD5E.jpeg



  • @LukeTheWalker has to be default fr command line

    do

    arecord test.wav
    

    speak something
    ctrl-c to end arecord

    aplay test.wav
    

    do u hear what u said?



  • @sdetweil yes I can I hear



  • @LukeTheWalker when u start up mm, do you see any errors in the window where u do npm start, or if u use pm2,
    pm2 logs --lines=???
    where ??? is a number, default 15



  • @sdetweil here is the log from running npm start dev:

    pi@raspberrypi:~/MagicMirror $ npm start dev
    
    > magicmirror@2.13.0 start /home/pi/MagicMirror
    > DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js "dev"
    
    [2020-11-09 22:20:24.369] [LOG]    Starting MagicMirror: v2.13.0
    [2020-11-09 22:20:24.382] [LOG]    Loading config ...
    [2020-11-09 22:20:24.393] [LOG]    Loading module helpers ...
    [2020-11-09 22:20:24.397] [LOG]    No helper found for module: alert.
    [2020-11-09 22:20:24.502] [LOG]    Initializing new module helper ...
    [2020-11-09 22:20:24.503] [LOG]    Module helper loaded: updatenotification
    [2020-11-09 22:20:24.505] [LOG]    No helper found for module: clock.
    [2020-11-09 22:20:25.317] [LOG]    Initializing new module helper ...
    [2020-11-09 22:20:25.318] [LOG]    Module helper loaded: calendar
    [2020-11-09 22:20:25.319] [LOG]    No helper found for module: compliments.
    [2020-11-09 22:20:25.321] [LOG]    No helper found for module: currentweather.
    [2020-11-09 22:20:27.118] [LOG]    Initializing new module helper ...
    [2020-11-09 22:20:27.119] [LOG]    Module helper loaded: MMM-awesome-alexa
    [2020-11-09 22:20:27.121] [LOG]    No helper found for module: weatherforecast.
    [2020-11-09 22:20:27.166] [LOG]    Initializing new module helper ...
    [2020-11-09 22:20:27.168] [LOG]    Module helper loaded: newsfeed
    [2020-11-09 22:20:27.169] [LOG]    All module helpers loaded.
    [2020-11-09 22:20:27.389] [LOG]    Starting server on port 8080 ... 
    [2020-11-09 22:20:27.408] [LOG]    Server started ...
    [2020-11-09 22:20:27.410] [LOG]    Connecting socket for: updatenotification
    [2020-11-09 22:20:27.411] [LOG]    Connecting socket for: calendar
    [2020-11-09 22:20:27.412] [LOG]    Starting node helper for: calendar
    [2020-11-09 22:20:27.413] [LOG]    Connecting socket for: MMM-awesome-alexa
    [2020-11-09 22:20:27.415] [LOG]    Connecting socket for: newsfeed
    [2020-11-09 22:20:27.416] [LOG]    Starting node helper for: newsfeed
    [2020-11-09 22:20:27.417] [LOG]    Sockets connected & modules started ...
    [2020-11-09 22:20:27.614] [LOG]    Launching application.
    [2020-11-09 22:20:37.287] [LOG]    Create new calendar fetcher for url: http://localhost:8080/modules/calendars/526b2266ca404c95648812c17dcb716454dc7796f89c0581ae65ee9228174e55.ics - Interval: 300000
    [2020-11-09 22:20:37.316] [LOG]    Create new calendar fetcher for url: http://localhost:8080/modules/calendars/cea74d97bef3bf37890989ecc073ff23f172a87c372189a17ebacd5c694df2a7.ics - Interval: 300000
    [2020-11-09 22:20:38.599] [LOG]    Create new news fetcher for url: https://www.ansa.it/sito/ansait_rss.xml - Interval: 300000
    [2020-11-09 22:20:38.859] [LOG]    Create new news fetcher for url: https://www.ansa.it/sito/notizie/tecnologia/tecnologia_rss.xml - Interval: 300000
    [2020-11-09 22:20:38.863] [LOG]    Create new news fetcher for url: https://www.ansa.it/sicilia/notizie/sicilia_rss.xml - Interval: 300000
    [2020-11-09 22:20:38.866] [LOG]    Create new news fetcher for url: https://www.ansa.it/canale_scienza_tecnica/notizie/scienzaetecnica_rss.xml - Interval: 300000
    [2020-11-09 22:20:38.881] [INFO]   Checking git for module: MMM-awesome-alexa
    [2020-11-09 22:20:39.968] [INFO]   Calendar-Fetcher: Broadcasting 0 events.
    [2020-11-09 22:20:40.128] [INFO]   Newsfeed-Fetcher: Broadcasting 17 items.
    [2020-11-09 22:20:41.719] [INFO]   Newsfeed-Fetcher: Broadcasting 27 items.
    [2020-11-09 22:20:42.049] [INFO]   Newsfeed-Fetcher: Broadcasting 57 items.
    [2020-11-09 22:20:42.318] [INFO]   Newsfeed-Fetcher: Broadcasting 34 items.
    [2020-11-09 22:20:42.496] [INFO]   Calendar-Fetcher: Broadcasting 3 events.
    [2020-11-09 22:21:01.334] [LOG]    Shutting down server...
    [2020-11-09 22:21:01.337] [LOG]    Stopping module helper: updatenotification
    [2020-11-09 22:21:01.338] [LOG]    Stopping module helper: calendar
    [2020-11-09 22:21:01.340] [LOG]    Stopping module helper: MMM-awesome-alexa
    [2020-11-09 22:21:01.341] [LOG]    Stopping module helper: newsfeed
    

    which is the same from the logs of pm2, no error logs even there



  • @LukeTheWalker ok, last debugging I can think of.
    open the developers window, ctrl-shift-i on the keyboard, select the tab labeled console and scroll up to see any errors. usually red text.


Log in to reply