MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MMM-SunnyPortal not loading

  • Hi,

    I found this tread describing exact the same issue I am experiencing with this module. Strange thing is that I got this module working for a few weeks, looking very good … but after a week of disabeling it I wanted it enabled again but to my disappointment it shows the Solar Panels title with beneath 4 times “Loading …” and that does not end.
    I tried reinstalling the SunnyPortal module, MagicMirror and even started from scratch with a complete new raspberrypi install but still no luck. I tried the fix from this ( MMM-SunnyPortal Solar Module](/topic/12184/mmm-sunnyportal-solar-module) thread but also no luck, after altering the node_helper.js file MagicMirror is not starting at all. Changed that back to the original version again.

    What I notice in de logging when starting MagicMirror is the following lines as soon as I activate the SunnyPortal Module:
    0|mm | [2020-11-12 16:38:52.747] [ERROR] If you think this really is an issue, please open an issue on GitHub:
    0|mm | [2020-11-12 16:38:52.814] [ERROR] Whoops! There was an uncaught exception…
    0|mm | [2020-11-12 16:38:52.816] [ERROR] TypeError: Cannot read property ‘1’ of null
    0|mm | at Request._callback (/home/pi/MagicMirror/modules/MMM-SunnyPortal/node_helper.js:134:121)
    0|mm | at Request.self.callback (/home/pi/MagicMirror/modules/MMM-SunnyPortal/node_modules/request/request.js:185:22)
    0|mm | at Request.emit (events.js:200:13)
    0|mm | at Request. (/home/pi/MagicMirror/modules/MMM-SunnyPortal/node_modules/request/request.js:1154:10)
    0|mm | at Request.emit (events.js:200:13)
    0|mm | at IncomingMessage. (/home/pi/MagicMirror/modules/MMM-SunnyPortal/node_modules/request/request.js:1076:12)
    0|mm | at Object.onceWrapper (events.js:288:20)
    0|mm | at IncomingMessage.emit (events.js:205:15)
    0|mm | at endReadableNT (_stream_readable.js:1154:12)
    0|mm | at processTicksAndRejections (internal/process/task_queues.js:84:9)
    0|mm | [2020-11-12 16:38:52.818] [ERROR] MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    0|mm | [2020-11-12 16:38:52.819] [ERROR] If you think this really is an issue, please open an issue on GitHub:

    Any idea what is going wrong here, above logging says it has got something to do with the node_helper.js file …

    help would be appriciated …



  • Hi Arjan,

    I also encountered the same problem and noticed that I was forced to create a more complex password on the portal, but even after changing the password, the problem remained…

    I got it working again by making use of the user-agent of the latest Firefox browser version, being:

    ‘User-Agent’: ‘Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0’

    So it seems that we have hit the same browser user-agent issue again as mentioned in post

    You can fetch the latest release from

    Can you confirm its working again?


  • @linuxtuxie

    Hi linuxtuxie,

    I have reinstalled it and it worked … for 1 day, I now have the same problem again …
    I’ve reinstalled it again, and it keeps on saying “Loading…”

    I’ve tried using some other user-agent strings from chrome and edge. With the Edge string I’ve got it working agian

    ‘User-Agent’: ‘Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.198 Safari/537.36 Edg/86.0.622.69’,

    But it feels buggy, I will report back when it it fails again …



Log in to reply