MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Force client https with server https already setup



  • I have a server with MM Server set up ready. I can access it with my browser via https serverd by nginx reverse proxy.
    The problem is when I want to use it on the client, by doing node clientonly --address mymm.xxx.com --port xxx, it says Syntax Error: Unexpected tocken < html>. I guess it is caused by my https redirects. If my reverse proxy recieve http request it will redirect http request to https via 307 code.

    So I changed the --address to --address https://mymm.xxx.com, this time it says http://https://mymm.xxx.com. Well, ok. I guess no way to use https?

    I can start the MM by using Firefox -kiosk option but it is also buggy, can’t promise it will go fullscreen 100%.

    And idea how to run my client with node via https? Or i really have to use the plain http?



  • @KisonHe why use the client? Just launch chromium_browser… see my run_start.sh script here
    https://github.com/sdetweil/MagicMirror_scripts

    for the syntax… I use this on pi0 where electron doesn’t exist.



  • @sdetweil Thanks for replying 🙂
    It seems chromium’s -kiosk option works better than Firefox. When I use Firefox it has quite a chance not actully going full screen. I think my problem is no more now.


Log in to reply