MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

So this just started today



  • I get a blank screen and says it cant reach a site. So I thought I would just restart the MagicMirror and all would be good. When I run the command npm start I get the following error.

    /home/mark/MagicMirror/node_modules/electron/dist/electron: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.7.1 start: sh run-start.sh
    npm ERR! spawn ENOENT
    npm ERR!
    npm ERR! Failed at the magicmirror@2.7.1 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    After looking I did an npm audit and npm audit fix. still the same issue.

    Any suggestions to fix this.

    Here is the full log

    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘start’ ]
    2 info using npm@6.9.0
    3 info using node@v10.15.3
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.7.1~prestart: magicmirror@2.7.1
    6 info lifecycle magicmirror@2.7.1~start: magicmirror@2.7.1
    7 verbose lifecycle magicmirror@2.7.1~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.7.1~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/mark/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
    9 verbose lifecycle magicmirror@2.7.1~start: CWD: /home/mark/MagicMirror
    10 silly lifecycle magicmirror@2.7.1~start: Args: [ ‘-c’, ‘sh run-start.sh’ ]
    11 info lifecycle magicmirror@2.7.1~start: Failed to exec start script
    12 verbose stack Error: magicmirror@2.7.1 start: sh run-start.sh
    12 verbose stack spawn ENOENT
    12 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:48:18)
    12 verbose stack at ChildProcess.emit (events.js:189:13)
    12 verbose stack at maybeClose (internal/child_process.js:970:16)
    12 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
    13 verbose pkgid magicmirror@2.7.1
    14 verbose cwd /home/mark/MagicMirror
    15 verbose Linux 4.15.0-129-generic
    16 verbose argv “/usr/bin/node” “/usr/bin/npm” “start”
    17 verbose node v10.15.3
    18 verbose npm v6.9.0
    19 error file sh
    20 error code ELIFECYCLE
    21 error errno ENOENT
    22 error syscall spawn
    23 error magicmirror@2.7.1 start: sh run-start.sh
    23 error spawn ENOENT
    24 error Failed at the magicmirror@2.7.1 start script.
    24 error This is probably not a problem with npm. There is likely additional logging output above.
    25 verbose exit [ 1, true ]


Log in to reply