MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

midori cant connect to localhost



  • Got magicmirror to start on a pi zero following instrustions that I found on this forum. Now when midori starts I’m getting a connection refused on localhost:8080. I can ping localhost fine from terminal and I’ve added /120 in my whitelist.



  • Did you figure out this error? I’m having the same problem



  • Honestly, I didn’t. I spent a few days off and on trying to get things going, finally I reached out to someone on the forum that had a working image and used that. I have a few more zero’s floating around though and I’m planning on trying again from scratch this weekend.



  • Hi Guy’s, I’m having the same issue here, stuck on midori telling me connection refused…

    Im working on a pi zero w with jessie lite



  • @bbdv @ottobot @d-sanchez i hope one of you, has found a solution for this problem?!

    i have the same



  • I have managed to get it working by adjusting the start up script in the etc/init.d/ directory:

    Instead of:
    cd ~/MagicMirror

    I changed it to :
    cd /home/pi/MagicMirror

    Worked great for over 2 week… until I updated MagicMirror, the same error returned…
    (Connection refused)



  • This post is deleted!


  • This post is deleted!


  • Got it back to work by starting all over.

    Here are my* notes/steps:
    *)I have gathered all these steps from all the contributers on this site.

    Start with a fresh Jessie lite image…

    sudo apt-get update
    sudo wget http://node-arm.herokuapp.com/node_latest_armhf.deb
    sudo dpkg -i node_latest_armhf.deb
    sudo apt-get install npm
    sudo apt-get install git
    cd /home/pi/
    git clone https://github.com/MichMich/MagicMirror
    cd MagicMirror
    sudo npm install (This will take 30+ minutes)
    sudo apt-get install midori
    sudo apt-get install unclutter
    sudo aptitude install xinit
    sudo apt-get install matchbox
    sudo nano /etc/init.d/startMagicMirror.sh

    #!/bin/bash
    ### BEGIN INIT INFO
    # Provides:          startMagicMirror.sh
    # Short-Description: startMM
    # Description:       starts MM
    ### END INIT INFO
    cd /home/pi/MagicMirror
    node serveronly &
    sleep 20
    

    sudo xinit /home/pi/startMidori.sh
    sudo chmod a+x /etc/init.d/startMagicMirror.sh
    sudo update-rc.d startMagicMirror.sh defaults 100
    sudo apt-get install x11-xserver-utils
    sudo nano /home/pi/startMidori.sh

    #!/bin/sh
    xset -dpms # disable DPMS (Energy Star) features.
    xset s off # disable screen saver
    xset s noblank # don’t blank the video device
    matchbox-window-manager &
    unclutter &
    midori -e Fullscreen -a http://localhost:8080
    

    sudo chmod a+x /home/pi/startMidori.sh
    sudo reboot



  • @bbdv did you use Jessie or Stretch for that?