MagicMirror fails to install during electron installation



  • I tried this with NodeJs 6 and 7. This happened today. Last week I installed it without problems on another Pi 3.

    These are the errors.

    Error: ENOENT: no such file or directory, lstat '~/MagicMirror/node_modules/electron/dist/resources'
    
    Error: ENOENT: no such file or directory, lstat '/opt/MagicMirror/node_modules/electron/dist/resources'
    npm WARN grunt-stylelint@0.8.0 requires a peer of stylelint@^7.8.0 but none was installed.
    npm WARN stylelint-config-standard@16.0.0 requires a peer of stylelint@^7.8.0 but none was installed.
    npm ERR! Linux 4.4.50-v7+
    npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
    npm ERR! node v7.9.0
    npm ERR! npm  v4.2.0
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    
    npm ERR! electron@1.6.6 postinstall: `node install.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the electron@1.6.6 postinstall script 'node install.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the electron package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node install.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs electron
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls electron
    npm ERR! There is likely additional logging output above.
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /root/.npm/_logs/2017-04-30T22_56_16_822Z-debug.log
    


  • I’ve checked the thread where everyone reported the issue and right now they are on it.
    Good news tho for those without patience. It seems that other module is causing all this trouble: xtract-zip@1.6.1 to 1.6.4 is interfering with post install.

    To solve this:

    npm uninstall extract-zip
    npm install extract-zip@1.6.0
    npm install electron
    


  • This worked for me to install electron. However I got a 404 on xtract-zip:

    npm ERR! 404  'xtract-zip' is not in the npm registry.
    

    I instead did:

    npm install extract-zip@1.6.0
    

    Also, I noticed I was getting errors for writing to the node_modules directories, so I used chown on them:

    sudo chown -R $(whoami) ~/.npm
    sudo chown -R $USER /usr/lib/node_modules
    

    Not sure if they all were needed, but I wanted to document all of my steps to hopefully help.



  • @mitchscobell

    my bad, typo there, Corrected now.

    I think we have discussed this in two different posts: https://forum.magicmirror.builders/topic/2457/electron-npm-error/22


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.