MMM-MyCommute


  • Module Developer

    @robiv8 yeah it does work for me perfectly. Can send you my latest config if you want?



  • Au das wäre sehr nett 😗



  • @aries1984
    Bitte mir dann auch wenn moglich.

    Thanks



  • Newbie here I guess i have to pay for Google API service right? without that this module not going to work correct?



  • @keyun21 You have to set up a pay account, including a credit card, but they give you a specific number of free accesses, and if you keep the module to a timeframe that you’d normally look at it, you’d have a hard time exceeding those uses.



  • @bkeyport said in MMM-MyCommute:

    @keyun21 You have to set up a pay account, including a credit card, but they give you a specific number of free accesses, and if you keep the module to a timeframe that you’d normally look at it, you’d have a hard time exceeding those uses.

    Thanks a lot I will look into to see how many I can get free and how to set up module to run specific times?


  • Module Developer

    Hi everybody,

    sorry for the late reply. Haven’t been here much in the last couple of weeks. Here’s my config:

        {
            module: 'MMM-MyCommute',
            position: 'bottom_right',
            header: 'Traffic',
            classes: 'default everyone',
            config: {
                apikey: 'your API Key',
                origin: 'Marienplatz 1, 80331 München',
                startTime: '05:00',
                endTime: '10:00',
                hideDays: [0, 6],
                destinations: [
                    {
                        destination: 'Belgradstraße 13, 80796 München',
                        label: 'Good Food',
                        mode: 'driving',
                        color: '#82E5AA'
                    }
                ]
            }
        },


  • Can this module support Japanese addresses?
    The default config and values work for me, but putting in Japanese addresses returns loading… forever.



  • This is great and very practical module! Everything is working on me but i would like to remain below USD200 (40K calls)/mo API call request. This means staying below 1.3K calls/day

    However, after installed I can see 570+ request call in 2 hours on Google API dashboard. This is despite setting pollFrequency: 1200000 (20mins interval) on MM config.

    Any help please?



  • MM is only loading the “loading…” text for this module. All my other modules are showing right. I am getting request on the Google API Console under the Directions API. So I believe that I must have the module installed correctly. Does anyone know why this would be happening?