Help Please I am new and unable to install correctly!



  • I am new and trying to install the magic mirror but this code comes up:

    Cloning MagicMirror Done!
    Installing dependencies …
    npm WARN deprecated isarray@2.0.1: Just use Array.isArray directly
    npm ERR! Linux 4.9.35-v7+
    npm ERR! argv “/usr/bin/nodejs” “/usr/bin/npm” "install"
    npm ERR! node v6.11.0
    npm ERR! npm v3.10.10
    npm ERR! file /home/pi/.npm/css/2.2.1/package/package.json
    npm ERR! code EJSONPARSE

    npm ERR! Failed to parse json
    npm ERR! Unexpected token ‘/’ at 1:1
    npm ERR! /github.com/reworkcss/css.git"},“homepage”:"https://github.com/reworkcss/css#re
    npm ERR! ^
    npm ERR! File: /home/pi/.npm/css/2.2.1/package/package.json
    npm ERR! Failed to parse package.json data.
    npm ERR! package.json must be actual JSON, not just JavaScript.
    npm ERR!
    npm ERR! This is not a bug in npm.
    npm ERR! Tell the package author to fix their package.json file. JSON.parse

    npm ERR! Please include the following file with any support request:
    npm ERR! /home/pi/MagicMirror/npm-debug.log
    Unable to install dependencies!
    pi@raspberrypi:~ $


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.