Alexa - Refresh Token



  • This is on a Pi3.
    I tried to obtain a refresh token with the given script ( auth_code.sh ),
    but no success, message :
    Konnte keinen Dateideskriptor finden, der auf die Konsole verweist.
    Something seems to be missing.
    Any other way to obtain that token :
    Thanks, Wolfgang



  • I am stuck at the same thing as you.
    I am waiting if anyone can help



  • I changed the open statement to chromium-browser and the script run, but when doing the second step :
    CLIENT_ID="my id"
    CLIENT_SECRET="my secret"
    CODE="ANsSkiyHyDzMtRmEGCCp"
    GRANT_TYPE="authorization_code"
    REDIRECT_URI="https://localhost:9745/authresponse"
    curl -X POST --data “grant_type=${GRANT_TYPE}&code=${CODE}&client_id=${CLIENT_ID}&client_secret=${CLIENT_SECRET}&redirect_uri=${REDIRECT_URI}” https://api.amazon.com/auth/o2/token

    I get an error message :
    {“error_description”:“The authorization grant type is not supported by the authorization server”,“error”:“unsupported_grant_type”}

    Thanks.



  • Problem solved, I got it to run.

    1. The problem around the grant request was a wrong code ( cut and paste error !!!).
    2. Then it run, but no micro ( snowboy related ).
      A rebuild of snowboy solved it.

    Now Alexa answers my questions !
    The come a bit delayed, but they come.
    Compred to the sample app, the response has quite a lot of delay.
    Any ideas to speed it up ?
    Thanks.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.