Help!! Frozen MM on Pi3



  • Hi all:

    I had a fully functioning MM install on a Pi3 and I wanted to try to add Alexa functionality. I installed Alexa following:

    https://lifehacker.com/the-simplest-way-to-build-a-raspberry-pi-powered-amazon-1794218212

    because I could not get the MMM-Alexa app through the Amazon sign-up.

    I was connected to the MagicMirror through an SSH and I had fixed the ip to 192.168.0.254 which was free and in my reserved area on my router. In working through the steps, it appeared that my USB sound card wasn’t working so I shifted to getting the sound card working for both recording and playback (I have one of those USB sound cards with both mic and headphone jacks). The very first step was to do an update and upgrade:

    $ sudo apt-get update
    $ sudo apt-get upgrade

    Well, it got through the update okay so I started the sudo apt-get upgrade command and left it alone. When I returned the SHH was disconnected and it seemed that an error had occurred somewhere. I rebooted and did an ipscan and I could not find my MagicMirror! No device at 192.168.0.254. It’s possible that in registering my Alexa app to Amazon (which was completed successfully) that the fixed ip had been overwritten to be a dhcp device but no other connected device appeared to be my magic mirror. I have TWO Echo dots and when I look at the devices on my router there are THREE Amazon devices. Does this mean that the Amazon registration redefined the ip address for the MM because I registered the Alexa app? I tried remotely logging into each of these devices but none replied, so I couldn’t login that way.

    So, I pulled the microsd card and put it in a new Pi3, connected a mouse, usb keyboard, hdmi monitor and a 2.5A, 5v microusb power connector to work on it directly. It boots up, opens my window environment and then the Magic Mirror. I get the captions but none of the internet content (its likely the machine is not connected to the internet). So I try to kill the Magic Mirror to get back to the windowing environment and it does not respond to any keystrokes or mouse clicks!! I’ve tried ctrl-c, ctrl-w, ctrl-q, ctrl-z, ctrl-x … and even the special functions keys that use to interrupt the MMM window so I could enter ctrl-c in it base window. In fact, even the caps-lock button does not even light up the LED on one of the keyboards … so it’s like the keyboard is not being recognized!! I’ve tried 2 keyboards, but neither allow me to interrupt.

    If the keyboard and/or mouse are not being recognized, how do I interrupt the boot sequence or the MM autostart before they start the MM?

    I really do not want to start over as I customized the MMM and had it where I wanted it configured.

    Any one have any magic to try to fix this??


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.