MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Screen turning off/on at a certain time(I think?)

  • So my MagicMirror seems to stop sending signal to the HDMI port sometimes(I think it’s at the same time everyday but i’m still trying to figure it out.) Also it seems to affect when the screen will turn on because sometimes in the morning the screen would have turned from black to actual MagicMirror display.
    It’s like if at a certain point it stops sending HDMI signal. Even if I connect remotely via VNC I can see my MagicMirror but even if I move the mouse around, the display doesn’t come back on the mirror itself.
    Also on my mirror If I press the screen’s on/off button I will see in the corner Analog/Digital (like if it’s trying to find a signal) and then the screen goes blank again.

    I tried to install xscreensaver and disable it, it doesn’t work.
    I did Go to LXDE-autostart config:

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    add the following lines:

    @xset s noblank
    @xset s off
    @xset -dpms

    I’m not sure where to check next. Can someone please help me?

  • I can confirm that for some reason my MagicMirror turns on by itself at 5:45am and turns off at 4pm everyday.

  • i made exactly what you described, but i launch the two scripts (one for off and one for on) via the crontab.

    Go again trough the MM install description for the pi and check all settings again.
    i made a error and put one line in the wrong place and had similar problems like you. Since i double checked it, everything is fine

Log in to reply