EADDRINUSE port error



  • Hi,

    Everytime my PI boots and it tries to start Magic Mirror V2.1.3 I get an error which google tells me is becuase the Port specified is in use. I changed this to port 8099 which was not in use and I get the same error. When i check to see what is using that port its Node.js.

    Any suggestions?

    Steve



  • This post is deleted!


  • The error:
    – Ready to go! Please point your browser to: http://localhost:8099
    Whoops! There was an uncaught exception…
    { Error: listen EADDRINUSE 127.0.0.1:8099
    at Object._errnoException (util.js:1019:11)
    at _exceptionWithHostPort (util.js:1041:20)
    at Server.setupListenHandle [as _listen2] (net.js:1344:14)
    at listenInCluster (net.js:1385:12)
    at GetAddrInfoReqWrap.doListen [as callback] (net.js:1494:7)
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:100:10)
    code: ‘EADDRINUSE’,
    errno: ‘EADDRINUSE’,
    syscall: ‘listen’,
    address: ‘127.0.0.1’,
    port: 8099 }
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?


  • Module Developer

    @screechyboy79 That is well-known bug. Sometimes, MM couldn’t be killed CLEARLY. In that case, just restart pm2 or npm.
    Maybe at the next time, This error might appear again. However currently there is no perfect solution found.



  • @Sean I’ve rebooted several times i have also as you suggested tried pm2/npm restarts which also doesnt have any effect. This isnt intermittent its every time I reboot


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.