MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Magic Mirror showing only black screen on PiZeroW -- node serveronly mode



  • I am new to Raspberry Pi so apologies if i’m doing some schoolboy errors
    I successfully installed Raspbian Stretch - kernel version 4.9 on my new PI ZERO W, i also setup the Wifi Etc and was able to surf the internet from my PI. I also then enabled SSH, VNC etc and was able to remotely connect.

    I then installed Magic mirror using the Auto Installer … so far all Good.

    I then got myself an API key from openweathermap.org and created the config.js and updated the API - Key and the Location Id to my city in this file.

    Next, i ran the command npm run config:check and i did not get any errors

    I finally tried to load this in Iceweasel (firefox) and all i get is a Black Screen and nothing else - i don’t get any errors on firebug as well – I have also tried the same on Midori and chromium and no luck on either. infact with Midori i get a Page not found error.

    i have also uploaded the file to jslint.com and only get use space not tabs warnings…no errors
    Any form of help much appreciated



  • Hi,
    If I remember correctly, I had a similar issue once.
    Can you try “npm install” while in the MagicMirror directory?



  • Works a treat mate - thanks for the Help - Much appreciated !!