MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Multiple Calendars problems with ICS Files bigger that 225 KB



  • Hi there,

    i installed today the Magic Mirror (V. 2.3.1) with the Batch and so far everything is working fine, but i have a bug, that had driven me crazy.
    I wanted to add 2 different Calendars which i automatically export from my Owncloud to an ICS File on my NAS, from where the Raspi with MagicMirror imports it with “localhost:8080…”. One Calendar worked from the beginning, the second one don’t wanted to show ANY entries. After 3 hours of testing i used a third and forth Calender and these instandly worked (even exported from the same Owncloud). Then i checked the ics files and the Calender with about 284 KB was the bigggest one. Calender one has 213 KB and the other have about 36 KB. When i open up the Calender Nr. 2 and Delete some rows by hand to reduce the size the file even works! The “Magic Size” is about 220 KB until 225 KB so that this file will work or not.

    Any idears how this could be fixed?

    If you want further informations i will send you the screenshots and Code and so on, but now i am such as tiered that i just want to fall in my bed ;o). G8


Log in to reply