MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Audio Recording Issue



  • Hello,

    I am working on my AlexiPi configuration. When the system boots, I get the “hello” playback on the speakers. I can play a sample wav file and it plays back just fine. When I record my voice as a test, it appears to be fine but when I play it back, it sounds like it was recorded at slow speed so playback makes my voice sound high pitched and fast (like a chipmunk or something). I’ve been working on troubleshooting this but have not yet found a solution. I think this is my last obstacle to getting Alexa working… I’m not sure what details I can post here as a starting point. Here is what I enter:

    arecord -f S16_LE -r 16000 -D pulse test.wa
    

    Here is what I use to play back:

    aplay -f S16_LE -r 16000 test.wav
    

    Here is the text output when it plays back:

    Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 16000 Hz, Mono
    

    My recording details:

    arecord -l
    **** List of CAPTURE Hardware Devices ****
    card 1: U0x46d0x809 [USB Device 0x46d:0x809], device 0: USB Audio [USB Audio]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    

    I’m hoping that someone may have some insight into this issue and can steer me in the right direction. Thank you in advance.



  • If u take off the rate, does it work ok?



  • @sdetweil said in Audio Recording Issue:

    If u take off the rate, does it work ok?

    I decided to wipe / rebuild the Pi and Magic Mirror install. I saved my configs etc. so it was pretty straight forward. I will leave this open incase I have the same issue again.

    One odd thing I noticed was that if I moved the USB mic to a different port, I could properly record my voice but AlexaPi was still not working with it. When I rebooted, the “munchkin voice” was back. Any suggestion around which Alexa install I should do? I tried AlexaPi last time but maybe I should just go with Awesome-Alexa (or some other?) Any thoughts?



  • It looks like the issue is around what I was attempting to use to record audio. I was using a Logitech Webcam 9000 Pro, intending to use just the microphone for the project. I ran out and bought a cheap desktop microphone to test and my voice recording now plays back normally. I assume there may be some kind of global sample rate which needs to be set for the microphone in the webcam (or drivers). I decided to just buy a Sony Playstation Eye from Amazon as I have read several stories of success with it. I will close this as solved since the cause has been identified even if the solution was not. Thank you for your help!