How do i make modules non-transparent



  • I have quite a few modules installed all working good and MMM-DropboxWallpaper posting pictures as a background. Some of the modules i have work fine they stay on top of other more common modules (like compliments) as they should, and have a “non-transparent” background while others are see though per say LOL.
    How do i change the background or the frame of a module to be non-transparent and stay on top of others (or not) for both these attributes in an as needed basis …I am sure there are setting to change in order to achieve that but i am aware of them so any help will be greatly appreciated
    Thank you
    D


  • Module Developer

    @richland007
    Add this in your ~/MagicMirror/css/custom.css, It will help.

    .module {
      background-color:rgba(0,0,0,0.5);
      border-radius: 20px;
      padding:10px;
    }
    

    But some modules which control it’s position by itself, will not be fit with this. In that case, find those elements and manually fix it.



  • @sean thank you it really did help 🙂



  • @sean I have been using the above sugestion of yours for the past few months however something strange happened. Last night i switched form cowboysdude fork and i downloaded your MMM-WeatherBackground after configuration of your module and starting to use it the above custom css no longer works although it is still in my custom.css file no one touched it!!!
    How is that possible and how do i get it back? I do not want my modules to be fully transparent i can’t see them with bright pictures in the background like the weather background or DropboxWallpaper.
    You know i appreciate any help i can get 🙂
    D


  • Module Developer

    @richland007
    His forked version (forked? I think it would be almost new build-up. 😃 ) is different with mine.
    It has its own feature to control opacity. See the instruction of module.
    https://github.com/cowboysdude/MMM-WeatherBackground#configuration



  • @sean I am not using his anymore just yours straight up but making the modules non transparent just like you advised me ceased to work when i downloaded MMM-WeatherBackground and i did not touch any of the custom.css settings it was working beautifully before


  • Module Developer

    @richland007
    I should see all your css/custom.css and config.js. Send me via email : eouia0819@gmail.com