MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

module for mm background



  • @surger13 said in module for mm background:

    What path did you specify in config.js to access your NAS?

    you need to use the ln command to make a soft link from the module folder to the NAS folder…

    ln -s source_path destination_path

    I did this using a folder name foo inside the /MMM-BackgroundSlideshow/exampleImages folder

    drwxrwxr-x 3 odroid odroid    4096 Feb  1 11:42 ./
    drwxrwxr-x 5 odroid odroid    4096 Feb  1 11:40 ../
    -rw-rw-r-- 1 odroid odroid  266282 Feb  1 11:40 245709.jpg
    -rw-rw-r-- 1 odroid odroid 1228351 Feb  1 11:40 245718.jpg
    -rw-rw-r-- 1 odroid odroid  966314 Feb  1 11:40 245742.jpg
    lrwxrwxrwx 1 odroid odroid      42 Feb  1 11:42 foo -> /mnt/buildserver/media/Photos/selectedpics/
    drwxrwxr-x 2 odroid odroid    4096 Feb  1 11:40 subfolder/
    


  • @surger13, I did it similar in way as @sdetweil but with extra steps☹ . I set up a new directory hpmv in the module folder with a symbolic link to the mounted directory in my case ~/Pictures/hpmv. Which required changing the imagePaths setting in config. I had challenges with getting the link to automount after rebooting. I finally got it to work without errors with this entry in /etc/fstab:
    //my.Nas.Ip.Addr/Photos /home/pi/Pictures/hpmv cifs guest,x-systemd.automount,vers=1.0 0 0 and by also using raspi-config setting to wait for network on boot.



  • @rts58 i had to change the imagePaths setting too…

    and automount is a pain… but needed…


  • Project Sponsor

    @sdetweil
    @rts58

    Thank you both. I have now temporarily mounted the nas and it works. A softlink only works on a mounted drive. That was the important hint for a beginner like me. I have to try the entry in the fstab next.

    Somewhat nasty is that the module also displays images from hidden folders. At least I get some pictures in low resolution.



  • @surger13 yes, sorry, didn’t mention mount was required to get access first before the link…

    hidden folders. that is a a surprise!