MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

ELIFECYCLE error after fresh install

  • Hi,

    I encountered a problem that was already mentioned in this post:
    But because this thread is unsolved and the last answer is more than 11 Months old I would like to try asking again for answers in this thread.

    I am currently setting my RasPi 3 B up from start.
    I downloaded the newest Raspbian with Desktop, installed and updated it and ran the one-line-command provided on the homepage.
    While installing I got 29 “vulnerabilities” which I solved with this “npm audit” and the recommended commands (somehow it threw these vulnerabilities stuff two times and as far as i understand the audit command only solved the vulnerabilities mentioned the second time).
    But now when trying to start the MagicMirror it tells me, there is an ELIFECYCLE error, probably not a problem with npm (see command prompt output).

    pi@raspberrypi:~/MagicMirror $ DISPLAY=:0 npm start
    > magicmirror@2.7.1 start /home/pi/MagicMirror
    > sh 1: ����������������������������������������������������������������������������������������������������������������������������������������������: not found
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.7.1 start: `sh`
    npm ERR! spawn ENOENT
    npm ERR! 
    npm ERR! Failed at the magicmirror@2.7.1 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2019-04-14T07_20_07_609Z-debug.log

    As you might notice there is a log created, but somehow the files in this directory change every few seconds so I didn’t manage to attach it. If you could tell me how to get the log I’ll be happy to upload it in this thread!

    I already tried running “DISPLAY:=0 npm start” and “npm start” all with the same result. Furthermore I also tried “npm rebuild” without success.

    I am very thankful for every answer and appreciate your effort!

    Kind regards,


  • Hi guys, I just wanted to say thank you to @bhepler and @sdetweil for trying to help me with this problem.

    In the end I just used a very old backup at first and updated it, which worked fine at first and yesterday I tried setting my RPi up from scratch again and it worked perfectly!

    I’m sorry for anybody who encounters the same error and tries finding answers here, sadly there doesn’t seem to be a perfect solution for this.


  • I have the same error from a previously working MagicMirror after rebooting it. I did not change any code, just rebooted the RPi.

  • @MrKnight230 can u show the output of npm -v

  • @Zwirbel if you go the MagicMirror folder and do a pm2 stop, then npm start what happens?

  • @sdetweil The Version is 6.4.1

  • @MrKnight230 thx… are u doing this over vnc? also the MM has to be running in graphical mode, unless u are running server only… (DISPLAY 0 will not exist if in VNC or text mode)

  • @sdetweil
    The RasPi is connected via HDMI to a Display and I’m using VNC to configure it. I had a previous install where everything worked with pm2 and manually using the command “npm start”.

  • @MrKnight230 sorry, do not know… there were lots of code changes by modules MM uses and have no control over.

    I cannot recreate this over ssh…

    my npm is version 6.9.0

    you might try

    npm install -g npm

  • @sdetweil Thanks for the suggestion, it successfully installed version 6.9.0 but sadly didn’t solve or even change anything about the problem.

  • @MrKnight230 ok, i can only think that the vnc start is not working now…

Log in to reply