MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

[MMM-RadioDe] - does not autoplay



  • Actually I have finished my Mirror and attached it on the wall. After starting the MagicMirror I realized that the MMM-RadioDe module does not start automatically, as it should and as previously did.
    In the past I set up my Pi with XVNC remote sessions and everything was working. The MMM-Radiode module was also starting automatically. A few weeks ago I updated my MagicMirror to 2.7.1 and now the module is still visible. If I connect to the Mirror via RDP session and press the Play button, it plays the set up radio station.
    I saw in the description of the module, without api_key the browser player will be displayed but will not start. But I have setted up an API Key. That’s why I’m wondering, why it is not working at the moment.
    Or could it be, that the API Key doesn’t work properly or has expired?
    Do you have any further suggestions to solve this issue?

    My config looks like:

    code_text
    {
    	module: 'MMM-RadioDe',
    	position: 'top_left', // This can be any of the regions.
    	config: {
    					// See 'Configuration options' for more information.
    					station: "1live",
    					// can be obtained in embed section of station, e.g. http://antennekids.radio.de/
    					api_key: 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX',
    					//optional,
    					height:"92", // in pixel
    					width:"360", // in pixel
    	}
    },


  • @ruffneck2 in the update MM uses an upgraded version of the browser that implements a new restriction, use must interact with screen before play is allowed…

    fix is to edit the MagicMirror/js/electron.js file and insert the line marked below (approx line 20)

    // Keep a global reference of the window object, if you don't, the window will
    // be closed automatically when the JavaScript object is garbage collected.
    let mainWindow;
    
    function createWindow() {
        app.commandLine.appendSwitch('autoplay-policy', 'no-user-gesture-required');  //< -------- added
    	var electronOptionsDefaults = {
    

    then close and restart mm

    i see there is a proposed fix in the next update (July)



  • @sdetweil Thank you very much, this hint actually resolved the problem.
    You mentioned that this also will be fixed in the next MM update in July.
    I hope, that adding this line doesn’t lead into further complications in the next update.



  • @ruffneck2 i don’t know if this change will make it in. I just see that someone submitted the change to be considered.


Log in to reply