MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

My MagicMirror screen keeps turning off



  • Hi,

    My MM screen keeps turning off every 120 minutes. I have turn off screen saver and I have followed the instructions and installed x11-xserver, but it doesn’t seem to work, and I’m too novice to know how to correct it.

    @xset s off
    @xset -dpms
    @xset s noblank
    

    Thank you for your help



  • @EhsanMomeni81 does the tv or monitor have a power off function? Sleep maybe?



  • @EhsanMomeni81

    120 minutes seems a long time for a screensaver or so.
    Normally that would be 5 to 15 minutes.

    Which exact file did you edit?

    There are, for example, multiple autostart files on your system and only one of them will work, depending on your debian version.
    To locate them:

    sudo find / -name autostart -type f
    


  • @sdetweil It’s the official RPi 7" screen, and what I can see no power off/sleep function



  • @evroom
    I edited the autostart which was stated in the MagicMirror guide

    sudo nano /etc/xdg/lxsession/LXDE/autostart
    


  • @EhsanMomeni81
    For Debian buster that seems to be right.
    For Debian stretch it is

    /home/pi/.config/lxsession/LXDE-pi/autostart
    

    On my Debian buster Pi with official RPI 7 inch screen, I have this for screen off after15 minutes.
    So, your xset settings seem right; have them like that on my other MagiMirror install (on Debian stretch) too.

    pi@raspberrypi:~ $ cat /etc/xdg/lxsession/LXDE-pi/autostart
    @lxpanel --profile LXDE-pi
    @pcmanfm --desktop --profile LXDE-pi
    @xscreensaver -no-splash
    point-rpi
    @xset s 900
    @xset s blank
    @xset -dpms
    

    @sdetweil made install scripts, so I guess he knows a bit more.



  • @evroom not for screen stuff yet



  • @evroom
    Sorry, but Debian buster and Debian stretch?

    I have a cronjob to turn off the screen at 11 pm until 6 am, which works, but other than that I want the screen to be on. Is it possible to change 900 to 61 200 (17 h) instead?



  • @EhsanMomeni81 said in My MagicMirror screen keeps turning off:

    Sorry, but Debian buster and Debian stretch?

    I guess you downloaded and installed an image with Debian, like from
    https://www.raspberrypi.org/downloads/raspbian/
    Debian Buster is the latest Debian version.

    With lsb_release -ayou can find out which version you have.

    If your cronjob works for turning on / off the screen, then I guess you do not need to use the @xset parameters to turn off the screen.

    This is what I currently have:

    For Debain Stretch (screen always on):

    $ cat /home/pi/.config/lxsession/LXDE-pi/autostart
    @lxpanel --profile LXDE-pi
    @pcmanfm --desktop --profile LXDE-pi
    @xscreensaver -no-splash
    @point-rpi
    @unclutter -display :0 -idle 3 -root -noevents
    @xset s noblank
    @xset s off
    @xset -dpms
    

    For Debian Buster (screen off after 900 seconds):

    $ cat /etc/xdg/lxsession/LXDE-pi/autostart
    @lxpanel --profile LXDE-pi
    @pcmanfm --desktop --profile LXDE-pi
    @xscreensaver -no-splash
    point-rpi
    @xset s 900
    @xset s blank
    @xset -dpms
    

    Not sure what the other entries do, I just appended the @xset lines to the existing entries.
    Will try what happens when I remove them a bit later.



  • @evroom said in My MagicMirror screen keeps turning off:

    Not sure what the other entries do

    To answer myself.

    lxpanel        0.10.0-2+rpt4 armhf        LXDE panel
    pcmanfm        1.3.1-1+rpt7 armhf        extremely fast and lightweight file manager
    point-rpi      0.20160905   armhf        Locate the mouse pointer over the menu button
    xscreensaver - not installed
    

    Using Debian Buster and a RPI 7 inch display, these settings should work for ‘screen always on’:

    @point-rpi          # locate the mouse pointer over the menu button
    @xset s off         # don't activate screensaver
    @xset -dpms         # disable DPMS (Energy Star) features.
    @xset s noblank     # don't blank the video device
    

    I left @point-rpias it sounds useful somehow; for screensaver settings not needed though.
    Will test it now.


Log in to reply