MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

I am givning up.. new install



  • I can’t get any mic to work on my MM, so I am think of doing a new install.
    But I wonder if I can save, my confi.js and the module folder, and swap them after the new install, so I don’t need to do it all over again.
    I have token, Alexa token and so on.
    So that files should’ve making copy’s of before, I wipe the sd card
    And what system should I install to get it right the right start:

    Raspbian Buster with desktop and recommended software
    Or

    Raspbian Buster with desktop
    Or
    Raspbian Buster Lite



  • @otto rename the MagicMirror folder to something else.

    Install again, copy stuff from old folder as needed



  • Before doing any reinstall check where is your mic with lsusb

    Mine is a webcam so I got the following:
    Bus 001 Device 012: ID 046d:0826 Logitech, Inc. HD Webcam C525

    Then I confirmed it was seeing my mic with arecord -l
    pi@raspberrypi:~/MagicMirror/config $ arecord -l
    **** List of CAPTURE Hardware Devices ****
    card 1: C525 [HD Webcam C525], device 0: USB Audio [USB Audio]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    So my device is plughw:1,0

    Try this to record 3 seconds and play it
    arecord -D plughw:1,0 -d 3 test.wav && aplay test.wav

    If sound is faint you can adjust the ‘gain’ by doing the following

    Open the Audio Device Settings :
    Open the Menu in the top left corner->Preferences -> Audio Device Settings

    I also tried with a 9$ amazon mic but the sound and recording was really crappy.

    Good luck!



  • @smassy the problem is when i go to alsamixe, and F6 and selcet the usb i whnat to use, i get this:

    pi@raspberrypi:~ $ alsamixer
    cannot load mixer controls: Ogiltigt argument

    and if go the settings i selcet the usb, it mutes the sound, cant use my spekars… is so stanges… i have been trying to fix this for over 4week now, and cant find any solution to it,



  • @otto said in I am givning up.. new install:

    cannot load mixer controls: Ogiltigt argument

    Did you tried the command I gave you? Thoses a just to validate that your mic is working, after you can work on alsamixer. The basic command are great tools to make sure stuff is working as you want.

    Maybe a long shot but did you tried the following solution provided here?
    https://askubuntu.com/questions/765396/alsamixer-cannot-open-mixer-invalid-argument

    It seems alsamixer can be tricky to config and some files need to be created manually (sound is muted by default at install).


Log in to reply