Out of curiousness - what's this error?



  • Was debugging a new module on my system, and noticed an error in the logs (lines before and after error included) - what modules would be hunting for github, and is there a way to set this username?

    I’m using the following modules: updatenotification, clock, worldclock, MMM-DarkSkyForecast, MMM-RTSPStream, MMM-MyCalendar, email, alert, and MMM-Remote-Control

    0|mm | Launching application.
    0|mm | fatal: could not read Username for ‘https://github.com’: No such device or address
    0|mm | Starting WebSocket server on port 9999. Waiting for connections…



  • @BKeyport The updatenotifications module



  • Ahh, is there a way to set my github credentials then?



  • @BKeyport shouldnt need any credentials.



  • I realize this is an old question but thought I’d provide a little more info just in case someone else stumbles upon this or you’re still looking for an answer.

    @sdetweil is correct in that the updatenotification is what is generating this error in the log.

    For the most part it can be ignored entirely as it doesn’t stop functionality from continuing.

    updatenotification module checks each module’s folder you designate in your config file. Within each of those folders it checks to see if it is hooked into git. If it is, then when the updatenotification triggers a check for updates, it will essentially run git fetch for each one of those folders its tracking.

    Now, if the remote is a private repository that requires credentials and you have not set those credentials local or global you then receive this error.

    I do not recommend setting your credentials for git locally or globally as this information is stored in plain text on your machine. However, if you still want to do this to avoid the error you can do the following:

    Navigate to a private repository folder on your Raspberry pi and execute the following:

    git config --global credential.helper store && git pull
    

    This will then ask for your credentials. Once you have provided them then all your private repositories will use the credentials you provided and you shouldn’t have to manually provide those credentials again. In turn, you will no longer see this error.



  • @DustinBryant thanks… I hadn’t experienced a private repo that needed credentials…