MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Google calender no events shown



  • Good afternoon, any help will be massively appreicated. So here goes. I cant get the google calender to work in the sense that no events ever appear .

    1. I have tried both public and private ical links. Both end in ics.
    2. I have pasted the ics file into a text editor and can see events
    3. The other modules update and work fine in regards to internet connection.
    4. Settings in my google cal are all set to show but nothing seems to be hidden and I can see everything up date on my syncd phone if edited via laptop .

    Can anyone help ?? Thanks



  • @mercuryskies put the https://… url into a browser on the pi. it should download the ics file…

    if not, its not shared correctly…

    the pi does not logon as you , like the windows browser does…

    if it does download, then open the developers window on the Mirror screen, ctrl-shoft-i, select the tab labeled ‘console’ and scroll up to see any errors…
    you can filter the messages too, by putting part of the module name in the filter field like ‘cal’ for calendar (no quotes)



  • @sdetweil thanks sam I will try this tonight and reply. Cheers



  • @sdetweil what could make it not share correctly ? As in settings in my Google account?
    I tried pasting the private and public url into my browser and it said the site cant be reached and that the server ip adress could not be found? Any thoughts? Thanks



  • @mercuryskies the link does say https:// not webcal:// right? if webcal, just change to https

    it said the site cant be reached and that the server ip adress could not be found
    but that is bigger problem than shared or not



  • @sdetweil yeah it reads
    Url: “https://calender.google.com/calender/ical and then my name and some random numbers letters etc and ends in ics” closed bracket



  • @mercuryskies

    mine is

    https://calendar.google.com/calendar/ical/sdetweil%40gmail.com/private-b01535955cdb72021e36fae98c08a186/basic.ics
    

    (number changed to protect the innocent!)

    if you go to your browser again and do

    https://calendar.google.com
    

    what happens?

    if u can’t reach the server, then the mirror cannot get the data



  • @sdetweil browser is fine. Also all my other internet dependant modules work ok. It is purely calender not showing events when the adress seems fine and all settings are set to allow



  • @mercuryskies please cut paste your calendar config. Change some of the coded numbers, but don’t change anything else. Use the code block to mark it

    Select all, hit the </>



  • Hi there, below is my calendar config. Thanks again, Michael.

    language: “en”,
    timeFormat: 12,
    units: “metric”,

    modules: [
    	{
    		module: "alert",
    	},
    	{
    		module: "updatenotification",
    		position: "top_bar"
    	},
    	{
    		module: "clock",
    		position: "top_left"
    	},
    	{
    		module: "calendar",
    		header: "Family Calender",
    		position: "bottom_left",
    		config: {
    			calendars: [
    				{
    					symbol: "calendar",
    					
    					url: "https://calender.google.com/calender/ical/michael.lloyd%40live.com/public/basics.ics", }
    					//url: "https://calender.google.com/calender/ical/michael.lloyd%40live.com/private-cf63bd901ffd72df081e7258123456789/basics.ics"  }
    											//url: "webcal://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics"					}
    			]
    		}