MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Mirror goes blank after 10 minutes...



  • Hey guys, I have followed the steps in “Configuring the Raspberry Pi” but my screensaver still seems to be on. I also checked my monitor and turned off all energy-saving settings so I am sure that the Pi is the issue. Any ideas? Thanks guys!



  • Have the exact same issue? Have you found a solution yet??



  • Ok, I did find a solution on a different forum in the interweb that did work. I post it here, so that if someone else is looking for the same thing, try the following:

    Before we start, I did this on a raspberry pi 3, there are a lot of solutions, but most of them don’t work on the pi3.

    To prevent the pi from going black, I used a little porgam thats called set.

    apt-get install x11-xserver-utils
    

    No you have to open the file: /etc/xdg/lxsession/LXDE/autostart,.

    Put the following stuff in it:

    xset s off # don't activate screensaver
    xset -dpms # disable Energy Star features
    xset s noblank # don't blank the video device
    

    Possibly also comment out the line that says @xscreensaver -no-splash, so the file should now look like this:

    @lxpanel --profile LXDE
    @pcmanfm --desktop --profile LXDE
    # @xscreensaver -no-splash
    xset s off 
    xset -dpms 
    xset s noblank
    

    As well make sure you did the stuff from the wiki in the /etc/kbd/config. In this file the following values should be set to the following:

    BLANK_TIME=0
    BLANK_DPMS=off
    POWERDOWN_TIME=0
    

    After you did all this, /reboot the pi.

    this worked for me… 🙂

    cheers, Flo