MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM - Remote Control URL calling issues..


  • Module Developer

    @Jopyth

    I’ve got two URL commands that aren’t working. I’d like some help to figure them out.

    Update: Trying to use “http://[address]/api/update” - I get back “Cannot GET /api/update”

    Restart: Again, using “http://[address]/api/restart” - I get back:

    Error: Cannot find module ‘pm2’
    at Module._resolveFilename (internal/modules/cjs/loader.js:602:15)
    at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
    at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/module-alias/index.js:49:29)
    at Function.Module._load (internal/modules/cjs/loader.js:528:25)
    at Module.require (internal/modules/cjs/loader.js:658:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Class.controlPm2 (/home/pi/MagicMirror/modules/MMM-Remote-Control/node_helper.js:867:23)
    at Class.executeQuery (/home/pi/MagicMirror/modules/MMM-Remote-Control/node_helper.js:654:22)
    at expressRouter.route.get (/home/pi/MagicMirror/modules/MMM-Remote-Control/API/api.js:170:18)
    at Layer.handle [as handle_request] (/home/pi/MagicMirror/node_modules/express/lib/router/layer.js:95:5)

    Thanks



  • @BKeyport try this syntax instead ip:port/remote?action=xxxxx&parms=???&parms2=???

    see
    https://forum.magicmirror.builders/topic/9941/mmm-remote-control-cannot-get-api/7


  • Module Developer

    Update: changing to other command works if all caps. UPDATE rather than update.

    Restart: Same error.



  • @BKeyport sorry, not quite sure what you said


  • Module Developer

    Update works with the http:// /remote?action=update

    Restart does the same error as above regardless of URL.


Log in to reply