MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-AssistantMk2 with Google AIY

  • I’ve followed all the instructions on in order to install the Google Assistant module. I am using the Google AIY kit with their special raspbian image made to work with it.

    I’m trying to get the module working with my mirror but I’ve encountered a couple of problems.

    First, the module will not appear on my mirror. This is the code I’ve put into my config.js file:
    It is just the simple configuration found on the module’s github page.

    Second, at some point during the installation of the module, it asked me to test my audio environment. The speaker did not play the google beep sound that was supposed to be played, and similarly the mic did not work. This concerns me as even if I am able to get the module to appear on my mirror, I’m sure it won’t function properly if the mic and speaker won’t pass this test. The odd thing is that Google has their own audio test built into their image of raspbian and both the speaker and mic work perfectly fine according to that test.

    I’m sorry, I have no programming experience and I’m attempting this project solely off of my intuition. Any help would be appreciated. Thanks!

  • @Croeder Howdy!

    I’m also working with the Google AIY kit, so I have a little experience to share. First, version 2 of the AssistantMk2 module does not, repeat not, work with the Google Hat. Not at all. A couple of us have found that out, and even the developer suggests that there is something wacky about Google’s use of the ALSA drivers or somesuch.

    The reason the moduel may not be showing up could be with having to rebuild electron, which is a documented bug for v2.

    I can report that v3 of the module will install on the Google Hat just fine, and will give you all the feedback and test results you want… BUT… right now there seems to be a memory issue with the module and they are still working on it. You can see my part of the discussion here:

    I have also tried installing the Google AIY assistant as a service, loading on startup. The advantage there is you get your LED button back. But I had issues with the responses cutting off and being weird, so I deinstalled that.

    Just waiting for results on version 3 now…!

  • Module Developer


    do you want to try to configure it with Google AIY ?

    i think, it should be possible 😉

    we can try if you want !

    @bugsounet (MMM-AssistantMk2 developer)

  • @nakedrabbit


    I appreciate the reply!

    I might be mistaken but I believe that I was running v3 of the module. Odd that it works for you but not for me. May be something with the hardware. I’m sure I’ll figure it out eventually though 👍

  • @Bugsounet

    Hey! Sorry for the late response. I’d love to try to configure it if you are still down!

  • Module Developer

    so, what is the problem at now ?

    memory issue ?
    playback issue ?
    configuring problem to find mic config ?

    for memory issue, i have some solutions …

    if it’s for AMK2 memory, i have solution
    if memory low is with MMM-Hotword, i have again a solution 🙂

    there many things to test 🙂

    Ready ?

  • @Bugsounet Sorry I was away for a bit.

    YES! I’m ready to try anything, including burning it all down and starting over. Let me know what I can do!

    My issues do not SEEM to be mic or speaker configs. When I install the tests all work just great. I do seem to have memory issues.

    Give me the tests! And thank you!

  • Module Developer

    So go on 🙂

    Generally memory problems are due to the use of sound via HTML5 (we don’t know really why)

    Let’s turn off and use the “native” sound of rpi

    in your config.js MMM-AssistantMk2

    let’s turn off HTML5 sound by using useHTML5: false
    if this feature don’t exist in your config

    wiki can help you to find needed block to add it

    Of course, you will have to restart MagicMiror after this modification

    awaiting your first return

  • @Bugsounet said in MMM-AssistantMk2 with Google AIY:

    useHTML5: false

    I’ve had that one in my config all along, so yes, I’ve accomplished this first step a while ago, still have the problem.

  • @Bugsounet NO WAIT!

    I did not configure properly! I did not realize the HTML5 option needed to be enclosed in the responseConfig section. Thanks for linking the wiki so I could double-check!

    No response yet. This is AssistantMk2 with your own snowboy option selected and Hotword NOT enabled. I’m going to try Hotword again now.

Log in to reply