MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

trouble with MMM-remote-control



  • hello, I have problems trying to use MMM-remote-control. I have downloaded everything and have copied the module into my config file. when I start the mirror it tells me my config file has a problem. This is the only module I have had issues with and I can’t get it to work.
    thanks



  • @thehoopjr that usually means a missing quote or comma,
    do
    cd ~/MagicMirror
    npm run config:check

    work from the top of the list… the error is typically reported on the line AFTER the error

    unexpected on line 45, means missing comma on line 44



  • @sdetweil thanks, I did that and it showed me where I went wrong but I don’t quite understand it. It’s telling me that it is expecting brackets to match earlier ones in the config file. Not too sure what to do, I’ve tried changing things to match what it’s telling me with no luck



  • @thehoopjr start from the top…

    var config = {
    
    modules: [
    {
    a module
    },
    {
    another module
    } 
    
    ];   end of modules list
    }   end of var config
    


  • @sdetweil All of that matches what I have in my config file. The check is only giving me errors in the remote module. it starts at line 90 and finishes at line 99.

    {
    module: "MMM-Remote-Control",					
    , position: "bottom_bar",
    config: {
    customCommand: {},  // Optional, See "Using Custom Commands" below
    customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
    showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    apiKey: "",         // Optional, See API/README.md for details
    	}
    },
    
    pi@jakemagicmirror:~/MagicMirror $ npm run config:check
    
    > magicmirror@2.10.1 config:check /home/pi/MagicMirror
    > node tests/configs/check_config.js
    
    Checking file...  /home/pi/MagicMirror/config/config.js
    Line 91 col 37 Extra comma. (it breaks older versions of IE)
    Line 92 col 9 Expected '}' to match '{' from line 90 and instead saw ','.
    Line 92 col 11 Expected ']' to match '[' from line 33 and instead saw 'position'.
    Line 92 col 19 Expected '}' to match '{' from line 11 and instead saw ':'.
    Line 92 col 20 Missing semicolon.
    Line 93 col 9 Expected an assignment or function call and instead saw an expression.
    Line 93 col 15 Missing semicolon.
    Line 93 col 9 Unrecoverable syntax error. (87% scanned).
    

    do you think you could point out any errors in there?
    thanks



  • @thehoopjr said in trouble with MMM-remote-control:

    Line 91 col 37 Extra comma. (it breaks older versions of IE)

    module: "MMM-Remote-Control",					
    , position: "bottom_bar",
    

    two commas in a row
    i hate his doc to uncomment that position line, with the leading comma

        module: 'MMM-Remote-Control'   // < --- notice this DOES NOT have the comma
        // uncomment the following line to show the URL of the remote control on the mirror
        // , position: 'bottom_left'   //< ---------- there
    


  • @sdetweil so I should remove that leading comma and it should fix it?



  • @thehoopjr leading or prior line trailing…
    just have 1… then try it…



  • @sdetweil that worked! thank you. the mirror started but all of my modules say they’re loading and the webpage won’t load. they’ve been stuck on loading for 10 minutes.
    any ideas?



  • @thehoopjr open the developers window, ctrl-shift-i, select the console tab, scroll up to find any errors (usually red text


Log in to reply