MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

White Screen with the message "The site can't be reached"



  • Good morning everyone, today at the end of the installation of my magic mirror, my screen displays: “The site can’t be reached”.
    so I did some research and with the command:

    pi@raspberrypi:~/MagicMirror $ node serveronly 
    

    I was able to get this error :

    pi@raspberrypi:~/MagicMirror $ node serveronly
    [2020-04-18 21:19:50.958] [LOG]    Starting MagicMirror: v2.11.0
    [2020-04-18 21:19:51.073] [LOG]    Loading config ...
    [2020-04-18 21:19:51.126] [LOG]    Loading module helpers ...
    [2020-04-18 21:19:51.145] [LOG]    No helper found for module: alert.
    [2020-04-18 21:19:51.906] [LOG]    Initializing new module helper ...
    [2020-04-18 21:19:51.923] [LOG]    Module helper loaded: updatenotification
    [2020-04-18 21:19:51.933] [LOG]    No helper found for module: clock.
    [2020-04-18 21:19:56.473] [LOG]    Initializing new module helper ...
    [2020-04-18 21:19:56.481] [LOG]    Module helper loaded: calendar
    [2020-04-18 21:19:56.494] [ERROR]  WARNING! Could not load config file. Starting                                                                                         with default configuration. Error found: TypeError: Cannot read property 'split                                                                                        ' of undefined
    [2020-04-18 21:19:56.504] [LOG]    Loading module helpers ...
    [2020-04-18 21:19:56.513] [LOG]    No helper found for module: alert.
    [2020-04-18 21:19:56.522] [LOG]    Initializing new module helper ...
    [2020-04-18 21:19:56.530] [LOG]    Module helper loaded: updatenotification
    [2020-04-18 21:19:56.540] [LOG]    No helper found for module: clock.
    [2020-04-18 21:19:56.549] [LOG]    Initializing new module helper ...
    [2020-04-18 21:19:56.555] [LOG]    Module helper loaded: calendar
    [2020-04-18 21:19:56.568] [LOG]    Whoops! There was an uncaught exception...
    [2020-04-18 21:19:56.575] [ERROR]  TypeError: Cannot read property 'split' of un                                                                                        defined
        at loadModule (/home/pi/MagicMirror/js/app.js:112:25)
        at loadNextModule (/home/pi/MagicMirror/js/app.js:165:5)
        at /home/pi/MagicMirror/js/app.js:167:6
        at Class.loaded (/home/pi/MagicMirror/js/node_helper.js:19:3)
        at loadModule (/home/pi/MagicMirror/js/app.js:148:6)
        at loadNextModule (/home/pi/MagicMirror/js/app.js:165:5)
        at /home/pi/MagicMirror/js/app.js:167:6
        at loadModule (/home/pi/MagicMirror/js/app.js:150:4)
        at loadNextModule (/home/pi/MagicMirror/js/app.js:165:5)
        at /home/pi/MagicMirror/js/app.js:167:6
    [2020-04-18 21:19:56.621] [LOG]    MagicMirror will not quit, but it might be a                                                                                         good idea to check why this happened. Maybe no internet connection?
    [2020-04-18 21:19:56.628] [LOG]    If you think this really is an issue, please...
    

    By deleting now my config.js file I have this result without any error:

    pi@raspberrypi:~/MagicMirror $ node serveronly
    [2020-04-18 21:27:39.144] [LOG]    Starting MagicMirror: v2.11.0
    [2020-04-18 21:27:39.257] [LOG]    Loading config ...
    [2020-04-18 21:27:39.291] [ERROR]  WARNING! Could not find config file. Please create one. Starting with default configuration.
    [2020-04-18 21:27:39.305] [LOG]    Loading module helpers ...
    [2020-04-18 21:27:39.751] [LOG]    Initializing new module helper ...
    [2020-04-18 21:27:39.762] [LOG]    Module helper loaded: updatenotification
    [2020-04-18 21:27:39.777] [LOG]    No helper found for module: helloworld.
    [2020-04-18 21:27:39.784] [LOG]    All module helpers loaded.
    [2020-04-18 21:27:41.147] [LOG]    Starting server on port 8080 ...
    [2020-04-18 21:27:41.324] [LOG]    Server started ...
    [2020-04-18 21:27:41.335] [LOG]    Connecting socket for: updatenotification
    [2020-04-18 21:27:41.344] [LOG]    Sockets connected & modules started ...
    [2020-04-18 21:27:41.354] [LOG]
    Ready to go! Please point your browser to: http://localhost:8080
    

    So I think the problem comes from my config.js so here it is:

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information on how you can configure this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
    	address: "localhost", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out or empty, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	useHttps: false, 		// Support HTTPS or not, default "false" will use HTTP
    	httpsPrivateKey: "", 	// HTTPS private key path, only require when useHttps is true
    	httpsCertificate: "", 	// HTTPS Certificate path, only require when useHttps is true
    
    	language: "fr",
    	timeFormat: 24,
    	units: "metric",
    	// serverOnly:  true/false/"local" ,
    			     // local for armv6l processors, default
    			     //   starts serveronly and then starts chrome browser
    			     // false, default for all  NON-armv6l devices
    			     // true, force serveronly mode, because you want to.. no UI on this device
    
    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: "clock",
    			position: "top_left"
    		},
    		{
    			module: "calendar",
    			header: "Calendrier",
    			position: "top_left",
    			config: {
    				calendars: [
    					{
    						symbol: "calendar-check",
    						url: "https://www.data.gouv.fr/fr/datasets/r/b580138b-ae5c-4b4d-8cbf-110ffd373192"					
                        }
    				]
    			}
    		},
    		{
    			//module: "compliments",
    			//position: "lower_third"
    		},
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "Aubenas",
    				locationID: "6454928", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "xxxx"
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "Aubenas",
    				locationID: "6454928", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "xxxx"
    			}
    		},
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "Le Monde",
    						url: "https://www.lemonde.fr/rss/une.xml"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true,
    				broadcastNewsFeeds: true,
    				broadcastNewsUpdates: true
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    

    thank you in advance



  • @CreatibOfficiel said in White Screen with the message “The site can’t be reached”:

      {
      	//module: "compliments",
      	//position: "lower_third"
      },
    

    u can’t just comment out the middle, you need to comment out the braces too…

    a better approach, is to add
    disabled:true,
    to the module definition, then no comments

    		{
    			module: "compliments",
                            disabled: true,
    			position: "lower_third"
    		},
    


  • @sdetweil Thank you very much.



  • @CreatibOfficiel So this is solved rite


Log in to reply