MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Having a blackscreen with no modules.



  • So I just freshly installed MM on Windows, (no installation error) now I want to it on windows/in browser to costumize/change things easier.

    This had worked before the “BIG 1.11 Update” but doesnt now.

    The weird things is, when I do “npm run server” the server starts (localhost:8080), the LOG says the modules are loaded, but I dont see them in my browser.

    I tried to fix it, but I dont really know what to do.

    I’d really appreciate the help and have anice day (:



  • @yaboi u had it on windows, now did an update to 2.11?

    did

    git pull
    npm install
    

    AND in EVERY module folder that has a package,json file do

    npm install  
    

    then on browser, ctrl-shift-i or f12 to open developers window, and find the console tab



  • @sdetweil Well, it installed it fresh, so did do any update? I mean “git pull” is unnecessary if I freshly installed?
    And for which reason should I open the console?

    And since I only have the defualt modules, none has a “package.json” file.

    Thanks for your reply.



  • @yaboi oh, fresh install on windows, black screen

    the developers window will give you errors that caused the black screen

    but on windows do this

    cd MagicMirror
    cd vendor
    npm install
    cd ..\fonts
    npm install
    cd ..\MagicMirror
    

    edit package.json
    change the start line from

        "start": "DISPLAY=\"${DISPLAY:=:0}\" ./node_modules/.bin/electron js/electron.js",
    

    to this

        "start": "node_modules/.bin/electron js/electron.js",
    


  • @sdetweil Wow, you are a true legend, I had this issue with “DISPLAY” before, but since in the error message it only said something is wrong in the “electron js”, I never found it.


Log in to reply