MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-awesome-alexa "WARNING! electron-v6.1-linux-arm/snowboy.node"



  • Hello everyone!!

    I spend lots of hours trying to solve this problem and i think i will need your help.

    I Installed the Magic Mirror on my Raspberry Pi 4 and it´s working normal.

    The problem is when I insert the Alexa module (MMM-awesome-alexa), and I start the Magic Mirror I only see a “Black Screen” with the cursor.

    I try to see what kind of problem I receive on terminal it shows like this:

    Capturar

    According this I try to see the file “snowboy.node” on /home/pi/MagicMirror/modules/MMM-awesome-alexa/node_modules/snowboy/lib/node/binding/Release/electron-v6.1-linux-arm/snowboy.node , but I don´t have the folder “electron-v6.1-linux-arm”.

    I have …/Release/node-v64-linux-arm, and is nothing inside.

    I see some one that had the same problem and recommend to use this command on the MMM-awesome-alexa directory:

    npm run electron-rebuild

    But I receive another error:
    Capturar-2

    I appreciate the help of all of you.

    Thanks fsdfsd


  • Module Developer

    in the same directory try:

    ./node_modules/.bin/electron-rebuild
    


  • @Bugsounet said in MMM-awesome-alexa “WARNING! electron-v6.1-linux-arm/snowboy.node”:

    ./node_modules/.bin/electron-rebuild

    Hello Bugsounet, tanks for your answer.

    I inserted that code on the MMM-awesome-alexa directory and I receive a message “No Such file or directory” image below.

    Capturar3

    I tried to install the module again using this steps: https://awesome-alexa.js.org/#/installation

    And i see that in this code :

    npm install --only=prod
    

    I receive some errors image below:
    Capturar4

    My problem is because of this errors installation?

    Really thanks for your help


  • Module Developer

    try installing electron-rebuild

    cd ~/MagicMirror/modules/MMM-awesome-alexa
    npm install electron-rebuild
    ./node_modules/.bin/electron-rebuild
    

    note:

    • i supose snowboy sources installed …
    • i don’t install this module 😉


  • Ok i used that code :

    Capturar6

    Afther that i try to open MagicMirror, the problem is the same “Black Screen” but now the error is different:

    Capturar7

    Really thanks for your help Bugsounet


  • Module Developer

    sorry, i can’t help you more, because i have not this module installed

    just maybe by trying npm install in alexa module directory (without --only-prod because it’s deprecied)

    if don’t work, i don’t know because it’s very old source and maybe unmaintened

    I see you open an issue in github, just wait a response



  • I tried to use that command on alexa module and i received some errors:

    3fb06689-3173-4230-a45c-6cd9cb67b968-image.png

    Ok i will wait for some more suggestions.

    Thanks Bugsounet for your help and if you have other suggestion I appreciate it!


Log in to reply