MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

macOS permissions



  • anybody that know anything about mac file system permissions might be able to help me…

    I have samba server share that is connected on logon to my catalina box.
    using the login items page

    if I open a terminal window, the share is there and usable

    I also have MM installed and the MMM-ImagesPhotos module. which has symbolic links to folders on the samba share

    if I start MM from the command prompt, via npm start, all works ok,
    if I start MM with pm2, (which does an npm start from the batch file), the share is not accessible…

    with this error reported from my code

     exception=Error: EPERM: operation not permitted, scandir '/selectedpics'
     exception=Error: EPERM: operation not permitted, scandir '/sp'
    

    this link seems to say if I could find ‘the application’ I could enable access
    https://osxdaily.com/2018/10/09/fix-operation-not-permitted-terminal-error-macos/

    I cannot find pm2 (it is outside my user space) /usr/lib/bin/pm2
    I tried making the electron.app thing as the application, but still doesn’t work.

    the share opens correctly at login
    pm2 starts MM correctly at login

    SO close…


Log in to reply