MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Remote control



  • @hawkeye you are replacing the contents of ~/MagicMirror/js/socketclient.js

    see this post for the (old) contents to put IN the file
    https://forum.magicmirror.builders/topic/12485/has-anyone-got-mmm-remote-control-working-on-mm-2-11/10?page=1



  • @sdetweil see your totally awesome that’s fixed now wahoo

    with your help im sure you could help me get this working awsome



  • @hawkeye i just searched in the forum on 2.11 remote control, that was the top result



  • I deleted every thing in the socketclient.js file and replaced with the following now the remote works like a charm

    var MMSocket = function(moduleName) {
    var self = this;

    if (typeof moduleName !== "string") {
    	throw new Error("Please set the module name for the MMSocket.");
    }
    
    self.moduleName = moduleName;
    
    // Private Methods
    self.socket = io("/" + self.moduleName);
    var notificationCallback = function() {};
    
    var onevent = self.socket.onevent;
    self.socket.onevent = function(packet) {
    	var args = packet.data || [];
    	onevent.call(this, packet);    // original call
    	packet.data = ["*"].concat(args);
    	onevent.call(this, packet);      // additional call to catch-all
    };
    
    // register catch all.
    self.socket.on("*", function(notification, payload) {
    	if (notification !== "*") {
    		notificationCallback(notification, payload);
    	}
    });
    
    // Public Methods
    this.setNotificationCallback = function(callback) {
    	notificationCallback = callback;
    };
    
    this.sendNotification = function(notification, payload) {
    	if (typeof payload === "undefined") {
    		payload = {};
    	}
    	self.socket.emit(notification, payload);
    };
    

    };



  • @hawkeye Thank you for posting. This corrected my problem! I have so much to learn. Off to my next issue with getting the Google Photos module to work.



  • @shawnlane said in Remote control:

    I have so much to learn.

    there was a bug in 2.11 for that file… fixes only come every 3 months… so the workaround it to put the old file back



  • its solved



  • Hi l see your having a similar problem as when add the script into my config file it stops l also remove the //
    To position it a the left bottom but it still didn’t work
    I set the IP. 0.0.0.0 and closed brackets []
    Set up any one on my IP address
    But it still no working.

    I know we should get a IP address on bottom of the mirror to type into our phone which open up app controller.

    If any can help us both please reply.



  • @videogame95 show the config for his module and aove/below it

    a module is

    {
       module:"name",
       position:"something",
       config: {
          ....
          module specifc values
          ...
        }
    },
    

    note that whre u add this MAY reqire a trailing comma on the last line of the prior module, meaning, more coming

    keep the braces and brackets aligned up and down,


Log in to reply