MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Cannot exit MM after recent update



  • I just updated my Magic Mirror setup (following the

    git pull && npm install
    

    )
    I had everything almost all set to get started with the Mirror, and now everything is all sorts of jacked up. I had my modules configured, APIs set up, and the Pi was configured.

    The Issue:

    • After the updating my local repo, I rebooted.
      • On reboot, pm2 took over and started MM.
      • Previously, I could ‘Ctrl + Q’, open the terminal, and ‘pm2 stop MM’
        • Now when I ‘Ctrl + Q’ MM will almost instantly reboot, not allowing me to get a terminal open to stop pm2.

    I have tried the Windows key to access Terminal that way and it does not work (it worked previously before updating). I have also tried minimizing the window: all this does is leave me with a black screen where I still cannot get to a terminal to stop pm2. Full shutdowns, reboots, nothing is working. MM has now taken over my Pi since the update. This was never an issue prior. All so I could simply get rid of the update notification at the top of the screen.

    *P.S. After the update, the forecasted weather has now shrunk down to 1 day. This is much less of a priority, I’m happy to troubleshoot this on my own once I can close the dang mirror and get back to a terminal/files.

    Thank you in advance!



  • @tasanford11 alt-spacebar, n
    should minimize the mm window.
    if u have another full screen black window, do alt-spacebar, n again. the desktop is back there.

    ctrl-q was never a good approach, as pm2’s job is to restart the app immediately if it goes gown unexpectedly.



  • @sdetweil

    Thank you for the help! This allowed me to get a Terminal emulator opened up and work backwards. I appreciate it!


  • Project Sponsor

    @tasanford11 ctrl+alt+t usually works for me. This pops open a terminal window immediately.


Log in to reply