MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-Remote-Control Help



  • Hi Guys,

    i have installed the module and updated my config.js file and i am able to connect to the remote.

    However i am getting the below message when i run npm run start on MagicMirror

    [2020-08-06 21:40:58.178] [ERROR] MODULE LIST ERROR: modules.json updating fail
    :EACCES: permission denied, open '/home/pi/MagicMirror/modules/MMM-Remote-Control/modules.json'
    [2020-08-06 21:40:58.179] [ERROR] ERROR_UPDATING
    [2020-08-06 21:40:59.566] [INFO] Checking git for module: MMM-Remote-Control
    [2020-08-06 21:40:59.645] [ERROR] error: cannot open .git/FETCH_HEAD: Permission denied
    

    Also whenever i make any changes with the remote i get the below error also:

    [2020-08-06 21:48:57.332] [ERROR] Whoops! There was an uncaught exception...
    [2020-08-06 21:48:57.333] [ERROR] [Error: EACCES: permission denied, open '/home/pi/MagicMirror/modules/MMM-Remote-Control/settings.json'] {
    errno: -13,
    code: 'EACCES',
    syscall: 'open',
    path: '/home/pi/MagicMirror/modules/MMM-Remote-Control/settings.json'
    }
    [2020-08-06 21:48:57.341] [ERROR] MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    [2020-08-06 21:48:57.342] [ERROR] If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    

    I’m quite new to all this so any help would be greatly appreciated.

    Kind Regards
    Michael



  • @mmcghee did u you use sudo git clone to install module??? or sudo unzip?



  • Hi,

    i used sudo git clone to install

    Michael



  • i also tried the automatic install and manual install too



  • @mmcghee said in MMM-Remote-Control Help:

    i used sudo git clone to install

    NEVER EVER use sudo , unless for specific command…

    SO, now have to fix it…

    here use sudo

    cd ~
    sudo chown -R pi MagicMirror
    

    this will change ownership of all files and folders from MagicMirror on down to pi from root (sudo sets user as root, but be root to take files away from root)



  • @mmcghee said in MMM-Remote-Control Help:

    i also tried the automatic install and manual install too

    what does that mean?

    only one MM install should be enough, again do NOT use sudo



  • Sorry in the MM-Remote-Control git page you have the option of doing either an auto installation or a manual installation. I dont know if the issue i have is something to do with PM2?


Log in to reply