MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

[Electron] display, MM faded away



  • Hello,
    I finally succeeded tonight in installing MMM-GoogleAssistant bugsounet then my Raspi started to slow down until it blocked, so I rebooted and since then I had to reinstall MMM-DHT-Sensor but above all my MM does not start anymore, appears instead: [Electron] see attached photo, I always have the same screen whether it is with the pm2 restart mm command or by closing the [Electron] window which opens automatically or by doing several reboots, there is always this [Electron] window.
    I do not want to start all over again … Would there be a diagnostic to launch and publish here to find out where the problem comes from and solve it by a command or reinstall a part that would have scratched?
    Thank you for your help.

    alt text



  • @RIKKO14 use the pm2 logs command to dump out the logs

    pm2 status
    pm2 stop 0
    pm2 logs --lines=100



  • @sdetweil thanks a lot for the pm2 logs command i found the error and fixed it. It works very well.


  • Module Developer

    Note: if MM is running with pm2. You can use pm2 log command for see logs in real time



  • @Bugsounet thanks for the Note.



  • it’s strange,
    sometimes I reboot my Raspberry the device card changes for my microphone plugged in USB, sometimes it is in device: "plughw: 1", sometimes in device: "plughw: 2", so I have to change it in my config.js


  • Module Developer

    Yes, i have too this issue sometime ago

    now it’s solved with lasted firmware (i think) because i don’t have this problem at now (RPI4)



  • @Bugsounet I was using a small SD card 8MEG and my logs got too full and kept things from running correctly.

    I had to pm2 flush to clear out the logs.
    and then restart and it worked.

    So I got a bigger sd card and have been working on the errors. I found changing the timer in the grove-gestures script got rid of a lot of timeout errors on it’s python script. I also made the news feed refresh less frequently and got less 401 errors from that. Now I can probably go back to the 8gb card. 🙂



  • @kayakbabe if u get 401 from newsfeed, turn off the module don’t let it just post errors to the log

    add

    disabled:true,
    

    after any module name to turn that module off



  • @sdetweil said in [Electron] display, MM faded away:

    disabled:true,

    I’m confused… if the module is still in the MagicMirror file and folder structure? is it still executed even if the module is completely commented out of the MagicMirror config.js? or does disabled:true; do the same thing as commenting it out?


Log in to reply