MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

One calendar wont load



  • Hi!
    I have problem with one of my calendars that wont show events. The problem started when updating to v2.13.0 and the calendar module caused the mirror to only show a blank screen. I solved it by outcomment the module and haven’t had time to dig into it for months until now.
    The problem back then I think was that I had changed the calendar names, so the url’s were wrong, so now I have solved it to show two calendars, but cannot see the last calendar’s event. I have tripple checked the ical-address, so that’s not the problem now. I have also gone through this link: https://github.com/MichMich/MagicMirror/issues/839 and tried to see if I got the same problem by run npm start dev but I wont get the same error message. This is my error message:

    > magicmirror@2.13.0 start /home/pi/MagicMirror
    > DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js "dev"
    
    /home/pi/MagicMirror/node_modules/electron/dist/electron: /lib/arm-linux-gnueabihf/libdbus-1.so.3: no version information available (required by /home/pi/MagicMirror/node_modules/electron/dist/electron)
    /home/pi/MagicMirror/node_modules/electron/dist/electron: /lib/arm-linux-gnueabihf/libdbus-1.so.3: no version information available (required by /home/pi/MagicMirror/node_modules/electron/dist/electron)
    [2020-12-30 22:08:23.415] [LOG]    Starting MagicMirror: v2.13.0
    [2020-12-30 22:08:23.433] [LOG]    Loading config ...
    [2020-12-30 22:08:23.447] [LOG]    Loading module helpers ...
    [2020-12-30 22:08:23.451] [LOG]    No helper found for module: alert.
    [2020-12-30 22:08:23.556] [LOG]    Initializing new module helper ...
    [2020-12-30 22:08:23.558] [LOG]    Module helper loaded: updatenotification
    [2020-12-30 22:08:23.564] [LOG]    Initializing new module helper ...
    [2020-12-30 22:08:23.567] [LOG]    Module helper loaded: mmm-systemtemperature
    [2020-12-30 22:08:23.570] [LOG]    No helper found for module: clock.
    [2020-12-30 22:08:24.566] [LOG]    Initializing new module helper ...
    [2020-12-30 22:08:24.569] [LOG]    Module helper loaded: calendar
    [2020-12-30 22:08:24.677] [LOG]    Initializing new module helper ...
    [2020-12-30 22:08:24.678] [LOG]    Module helper loaded: MMM-YrThen
    [2020-12-30 22:08:25.787] [LOG]    Initializing new module helper ...
    [2020-12-30 22:08:25.789] [LOG]    Module helper loaded: mmm-weatherchart
    [2020-12-30 22:08:25.844] [LOG]    Initializing new module helper ...
    [2020-12-30 22:08:25.845] [LOG]    Module helper loaded: newsfeed
    [2020-12-30 22:08:25.846] [LOG]    All module helpers loaded.
    [2020-12-30 22:08:26.086] [LOG]    Starting server on port 8080 ...
    [2020-12-30 22:08:26.114] [LOG]    Server started ...
    [2020-12-30 22:08:26.116] [LOG]    Connecting socket for: updatenotification
    [2020-12-30 22:08:26.118] [LOG]    Connecting socket for: mmm-systemtemperature
    [2020-12-30 22:08:26.119] [LOG]    Starting node helper: mmm-systemtemperature
    [2020-12-30 22:08:26.120] [LOG]    Connecting socket for: calendar
    [2020-12-30 22:08:26.121] [LOG]    Starting node helper for: calendar
    [2020-12-30 22:08:26.122] [LOG]    Connecting socket for: MMM-YrThen
    [2020-12-30 22:08:26.124] [LOG]    MMM-YrThen 12/30/2020 10:08:26 PM: Starting helper for MMM-YrThen
    [2020-12-30 22:08:26.125] [LOG]    Connecting socket for: mmm-weatherchart
    [2020-12-30 22:08:26.126] [LOG]    Starting node helper: mmm-weatherchart
    [2020-12-30 22:08:26.129] [LOG]    Connecting socket for: newsfeed
    [2020-12-30 22:08:26.131] [LOG]    Starting node helper for: newsfeed
    [2020-12-30 22:08:26.133] [LOG]    Sockets connected & modules started ...
    Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank"
    [2020-12-30 22:08:26.336] [ERROR]  Whoops! There was an uncaught exception...
    [2020-12-30 22:08:26.341] [ERROR]  Error: listen EADDRINUSE: address already in use 127.0.0.1:8080
        at Server.setupListenHandle [as _listen2] (net.js:1226:14)
        at listenInCluster (net.js:1274:12)
        at GetAddrInfoReqWrap.doListen [as callback] (net.js:1413:7)
        at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:65:10) {
      code: 'EADDRINUSE',
      errno: 'EADDRINUSE',
      syscall: 'listen',
      address: '127.0.0.1',
      port: 8080
    }
    [2020-12-30 22:08:26.363] [ERROR]  MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    [2020-12-30 22:08:26.366] [ERROR]  If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    [2020-12-30 22:08:26.380] [LOG]    Launching application.
    

    I have also checked the ical.js solution, but I don’t know how to solve it, because I only have a folder with that name and cannot create a file.
    I don’t have a lot of programming knowledges so please kind answers 🙂



  • @kvicksson u have another mm running already.

    pm2 stop 0



  • @sdetweil thanks! but it only seems like I have one instance running because now nothing is running.



  • Ok, so maybe I had something running in the background that I couldn’t see. When I ran npm start dev I got this error instead:

    [2020-12-30 22:53:03.906] [ERROR]  Whoops! There was an uncaught exception...
    [2020-12-30 22:53:03.908] [ERROR]  TypeError: Cannot read property 'iana' of undefined
        at getIanaTZFromMS (/home/pi/MagicMirror/node_modules/node-ical/ical.js:108:30)
        at /home/pi/MagicMirror/node_modules/node-ical/ical.js:175:23
        at Object.DTSTART (/home/pi/MagicMirror/node_modules/node-ical/ical.js:457:32)
        at Object.handleObject (/home/pi/MagicMirror/node_modules/node-ical/ical.js:483:39)
        at Object.parseLines (/home/pi/MagicMirror/node_modules/node-ical/ical.js:534:18)
        at Object.parseICS (/home/pi/MagicMirror/node_modules/node-ical/ical.js:590:18)
        at Object.sync.parseICS (/home/pi/MagicMirror/node_modules/node-ical/node-ical.js:190:15)
        at Object.autodetect.parseICS (/home/pi/MagicMirror/node_modules/node-ical/node-ical.js:221:17)
        at Request._callback (/home/pi/MagicMirror/modules/default/calendar/calendarfetcher.js:79:22)
        at Request.self.callback (/home/pi/MagicMirror/node_modules/request/request.js:185:22)
    


  • Update: solved the problem by using your solution here: https://forum.magicmirror.builders/topic/13770/2-13-calendar-fix-for-office-365-users but I don’t have a Office 365-account.
    Thanks for the solution!!



  • @kvicksson if u download the ics file, put the url in a browser on your pc, and can send me the file
    I will look at it…

    my email in the same user-defined as here at Gmail.

    its a text file, so u can edit /cleanse it if u need to

    that error happened in the 1st fix for Microsoft timezone names. I never thought the lookup i built would fail… oops…



  • @kvicksson that code will be in the new release on Friday, 1/1


Log in to reply