MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Mirror won't start - Command line error [Details inside]



  • Hello magic mirror forum

    Background info

    Please forgive me for asking very basic questions I am very new to the Raspberry Pi and Linux, I have been trying to read through doucmentation and various forums for the last hour and a half and can’t seem to get to the bottom of this issue so I was hoping someone might be kind enough to help me out.

    I have used the auto install method for the MagicMirror.

    curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh | bash
    

    I have then browsed through the files and changed the config file to

    config.js
    

    I used the windows browser rather than using the command line to change the file name (I’m not sure if this matters but thought I would mention it just in case.

    Problem

    When I type this in to the command line

    ~ $ cd MagicMirror/config
    

    I get the following message

    bash: /home/pi: Is a directory
    

    Can anyone tell me what is going on and how I fix it please?

    Thanks for your help 🙂



  • @1uke_

    Rather than

    ~ $ cd MagicMirror/config
    

    just type

    cd MagicMirror/config
    


  • Hi thanks for the reply,

    I actually see the glaringly obvious mistake I made.

    ~ $ was already at the command line and I was retyping it.

    Thanks for helping me with this @in_a_days.

    I am now having a new issue getting the MagicMirror to start. I wondered if you might look over the problem. You can read about it here