Jenkins RSS feed

  • So it seems I have proxy problems, sometimes I can access my local Jenkins sometimes I can access public MovingBlocks but not both … I have to look into that.

    Thansk a lot for your support, I’ll come back to you whan I’m done 🙂

  • Core Contributors

    @BeatIdo said in Jenkins RSS feed:

    { Error: unable to get local issuer certificate
    at Error (native)
    at TLSSocket. (_tls_wrap.js:1079:38)
    at emitNone (events.js:86:13)
    at TLSSocket.emit (events.js:185:7)
    at TLSSocket._finishInit (_tls_wrap.js:603:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:433:38) code: ‘UNABLE_TO_GET_ISSUER_CERT_LOCALLY’ }

    That’s interesting.

    What happens when you run?

    curl -Iv

  • @roramirez nice test, it seems it confirms my proxy problem.

    When I run this command directly on my RPi which lacks proper proxy configuration I got a “Network unreachable” error.

    Interestingly enough if I connect though SSH to the same RPi from my PC whcih has proxy configured the command gets proxy authorization and get answers from http server.

    I’ll try to configure proxy accordingly and got through this.

    HEAD /jenkins/rssAll HTTP/1.1
    User-Agent: curl/7.38.0
    Accept: /

    < HTTP/1.1 200 OK
    HTTP/1.1 200 OK
    < Date: Fri, 24 Feb 2017 08:06:31 GMT
    Date: Fri, 24 Feb 2017 08:06:31 GMT
    < Content-Type: application/atom+xml;charset=UTF-8
    Content-Type: application/atom+xml;charset=UTF-8
    < Connection: close
    Connection: close
    < Set-Cookie: __cfduid=de5c9bf89dbae2ffefd003694243d657a1487923591; expires=Sat, 24-Feb-18 08:06:31 GMT; path=/;; HttpOnly
    Set-Cookie: __cfduid=de5c9bf89dbae2ffefd003694243d657a1487923591; expires=Sat, 24-Feb-18 08:06:31 GMT; path=/;; HttpOnly
    < X-Content-Type-Options: nosniff
    X-Content-Type-Options: nosniff

    • Server cloudflare-nginx is not blacklisted
      < Server: cloudflare-nginx
      Server: cloudflare-nginx
      < CF-RAY: 33616b2f2e483c5f-CDG
      CF-RAY: 33616b2f2e483c5f-CDG


    • Closing connection 0
    • SSLv3, TLS alert, Client hello (1):

  • Everything I tested this morning about proxy configuration did not work while starting MM through SSH connection using “node serveronly” command. Even accessing my local Jenkins server did not work …

    Afterwards I tried starting MM directly from MM GUI using “npm start” command this worked for local servers access …

  • I can confirm now my problem came from proxy configuration, module just didn’t handle error response which was not feed formatted.