No calendar or News feed?!?!?



  • I have been racking my brain for the past 3 hours on this problem. I am running this using pm2 and there are no errors what so ever in the logs nor the firebug console. I am running it as serveronly as this system is only ssh at the moment as i do not have monitor yet. I have tried both the defaults settings as well as my own cal and new links and the screen only says loading. Thats it. Help? **Edit: I almost forgot to include the url to access the test enviroment http://107.170.145.134:8080/



  • What happens when you call the urls from your calendar und news feed out of the config.js file directly in a browser? Do you see any content?



  • They work fine. I have checked to make sure they were correctly formatted and everything.



  • were you using the browser on your raspi or one on another computer? because both modules connecting to the internet are not working, this could indicate a problem with the internet connection or proxy



  • Connecting to pi in another location entirely on a different internet connection. Browsers on both ends show the same.



  • what urls are you using? the javascript script code says that when no news items are found, the Loading… is shown.



  • Tried with both the default and a local feed. both had content in their xml when i checked manually. and the private google calendar link that i am using is processing ical correctly when i checked also when testing i was getting responses from the weather api and it was throwing a non valid api error so i disabled those modules to help clean up console activity


  • Moderator

    Did you make any changes to your config.js file (like most of us do)? If so, can you try running the default config.js that comes with MM? Rename your current config.js to something else, and rename the config.js.sample to config.js. Reload the mirror (not just refresh your browser, reload the whole node process on the rpi.)

    With the default config, you should get an error on the weather modules, but the others should work. Please report back.



  • It does it even with the default config. That is when i first noticed it and thought well maybe those feeds are down so i changed them and still the same. got the error with weather like i was supposed to. I have done a reinstall of everything 3 different times now all the way from reinstalling os up.



  • And did you check the /home/pi/.pm2/logs log-files?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.