MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Fresh install MM2 RP3 wont start :(



  • Hi I have installed MagicMirror2 5 times now and still get to the same issue of not starting up.
    Setup
    Raspberry pi 3
    Jessie Full
    Auto Installer MagicMirror

    I have used the Automatic Installer (Raspberry Pi Only!)
    OK the first time i used Raspbian Stretch Lite but then i moved to Raspbian Stretch Full wont start.

    After some googling i came across a link to install it with Raspbian Jessie Full
    complete-setup-tutorial

    Here is my
    npm-debug.log

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
    2 info using npm@3.10.10
    3 info using node@v6.12.3
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle magicmirror@2.2.2~prestart: magicmirror@2.2.2
    6 silly lifecycle magicmirror@2.2.2~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.2.2~start: magicmirror@2.2.2
    8 verbose lifecycle magicmirror@2.2.2~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.2.2~start: PATH: /usr/lib/node_modules/npm/bin/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    10 verbose lifecycle magicmirror@2.2.2~start: CWD: /home/pi/MagicMirror
    11 silly lifecycle magicmirror@2.2.2~start: Args: [ '-c', 'sh run-start.sh' ]
    12 silly lifecycle magicmirror@2.2.2~start: Returned: code: 1  signal: null
    13 info lifecycle magicmirror@2.2.2~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.2.2 start: `sh run-start.sh`
    14 verbose stack Exit status 1
    14 verbose stack     at EventEmitter. (/usr/lib/node_modules/npm/lib/utils/lifecycle.js:255:16)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at EventEmitter.emit (events.js:191:7)
    14 verbose stack     at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/spawn.js:40:14)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at ChildProcess.emit (events.js:191:7)
    14 verbose stack     at maybeClose (internal/child_process.js:920:16)
    14 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:230:5)
    15 verbose pkgid magicmirror@2.2.2
    16 verbose cwd /home/pi/MagicMirror
    17 error Linux 4.9.78-v7+
    18 error argv "/usr/bin/node" "/usr/bin/npm" "start"
    19 error node v6.12.3
    20 error npm  v3.10.10
    21 error code ELIFECYCLE
    22 error magicmirror@2.2.2 start: `sh run-start.sh`
    22 error Exit status 1
    23 error Failed at the magicmirror@2.2.2 start script 'sh run-start.sh'.
    23 error Make sure you have the latest version of node.js and npm installed.
    23 error If you do, this is most likely a problem with the magicmirror package,
    23 error not with npm itself.
    23 error Tell the author that this fails on your system:
    23 error     sh run-start.sh
    23 error You can get information on how to open an issue for this project with:
    23 error     npm bugs magicmirror
    23 error Or if that isn't available, you can get their info via:
    23 error     npm owner ls magicmirror
    23 error There is likely additional logging output above.
    24 verbose exit [ 1, true ]
    
    

    And a screen shot of my
    PM2 Info MagicMirror
    alt text

    I really hope you can help me thanks :):)



  • @paddyhughes

    did u try it manually yet?
    https://forum.magicmirror.builders/topic/5274/how-to-manually-install-mm-on-your-pi-for-absolute-beginners/3

    Remove your actual MagicMirror folder and try it like described in the link



  • @cruunnerr

    Hi Thanks for the suggestion. just followed them steps
    i am now getting the following errors when i run npm start

    error code ELIFECYCLE
    err! Errno 1
    0_1517177314711_IMG_9371 (1).JPG

    I have a second Sd Card i am going to try it on Raspbian Stretch Full and see if i can get it working

    Thanks for all the support guys



  • Hi so it Just worked.

    i was logged in and installed MagicMirror in CLI mode
    Just before i decide to move to a new SD card i changed the CLI to GUI in sudo raspi-config
    and rebooted the pi once it logged it the MagicMirror kicked in after about 20seconds

    Did i do something wrong should i have always had the GUI enables and just worked in terminal
    if so. Sorry my bad…

    Also any way for the MagicMirror to start quicker with out seeing the GUI Desktop



  • @paddyhughes Yeah, MM relies on the GUI to display the browser. It’s possible to run without a GUI, but it requires some extra packages and effort. Sorry, didn’t think to ask, but glad to hear it’s up and running!



  • @ninjabreadman

    No i realy happy i got it working thanks everyone for all the help

    Alot of great support gong on in the forms

    Big Thumbs up to you all

    Thanks