Problems with port 8080



  • So my fitbit module stopped working yesterday morning. When I tried to set up a new token and credential file I was met with the following error. Could someone please help me figure out why the module is no longer working and what this error means.

    File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/servers.py”, line 439, in wait_for_free_port
    raise IOError(“Port %r not free on %r” % (port, host))
    IOError: Port 8080 not free on ‘127.0.0.1’

    [28/Sep/2016:20:05:20] ENGINE Shutting down due to error in start listener:
    Traceback (most recent call last):
    File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/wspbus.py”, line 243, in start
    self.publish(‘start’)
    File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/wspbus.py”, line 223, in publish
    raise exc
    ChannelFailures: IOError(“Port 8080 not free on ‘127.0.0.1’”,)

    [28/Sep/2016:20:05:20] ENGINE Bus STOPPING
    [28/Sep/2016:20:05:20] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer((‘127.0.0.1’, 8080)) already shut down
    [28/Sep/2016:20:05:20] ENGINE Stopped thread ‘_TimeoutMonitor’.
    [28/Sep/2016:20:05:20] ENGINE Stopped thread ‘Autoreloader’.
    [28/Sep/2016:20:05:20] ENGINE Bus STOPPED
    [28/Sep/2016:20:05:20] ENGINE Bus EXITING
    [28/Sep/2016:20:05:20] ENGINE Bus EXITED


  • Moderator

    You have something else on port 8080. Figure out what, change it, and the problem is fixed.

    NOTE: MagicMirror runs on port 8080 by default.



  • @KirAsh4 I’m trying to learn how to do this. I am new to programming in general and was hoping someone could point me in the right direction or at least how to start trying to solve this issue on my own. The only stuff I have installed on my pi is magic mirror with the fitbit module and Weaved.


  • Moderator

    If your FitBit application requires running on port 8080, you will run into exactly the problem you have because MagicMirror also runs on that same port. You will have to change one of them. MagicMirror is easy to change, it’s in the config.js file. Change the port setting to something else, like 8081 …or 8585 … or 8123 … doesn’t matter, as long as it’s above 8000, and not 8080 since the Fitbit runs on that port.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.