MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Web cam problem please help me T.T



  • We are now using Microsoft’s hd-3000 as a Raspberry Pi webcam. This webcam has a built-in microphone. Before we start the program, stop the stream with sudo service motion stop and start npm start, then the webcam’s signal is blink and voice recognition will bring up Python. However, after a month, if we start npm start with a raspberry pi , it will not be able to recognize the voice and it does not signal to the webcam. I have a webcam problem, but when I run the Python code separately, the webcam gets a signal and runs fine. I do not know if it’s a problem with the webcam or if it does not accept the voice itself from Raspberry Pi. If we start npm and speak the speech recognition word, there is no error code and Python does not run.



  • @pkj i use a webcam on my MM as well, and use github motion for my MM-SleepWake module, and MM-voice/HelloLucy for the voice recognition

    none of that uses python.

    On a different Smart mirror platform (smart-mirror) that uses arecord to capture the voice sounds, there is a problem like u describe, due to a bug in arecord, but it starts to fail around 20 consecutive hours…

    what modules are u using?



  • @sdetweil I use voicecontrol module and camera module. !!! and when i typed lsusb commands there were my webcam device. But when i typed arecord -l , there were nothing



  • i see this
    -l = -L (lowercase)

    ~/MagicMirror/modules$ arecord -l
    **** List of CAPTURE Hardware Devices ****
    card 1: U0x46d0x825 [USB Device 0x46d:0x825], device 0: USB Audio [USB Audio]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    

    also the bug i spoke to is also using Snowboy… the bug is that when spooling audio via stdout, arecord’s size counter wraps at 18 hours(2gig) , and no more audio is captured. only fix is to kill arecord and restart it (means restarting mirror app)



  • @sdetweil Thank you so much! Anyway I solved this problem!



  • @pkj what did you do to fix the problem?


Log in to reply