MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

MMM-Hotword



  • @sean said in MMM-Hotword:

    npm install

    Thanks for your reply. I ran the suggested commands.

    pi@raspberrypi:~/MagicMirror/modules/MMM-Hotword $ npm install nan
    

    and then

    pi@raspberrypi:~/MagicMirror/modules/MMM-Hotword $ npm install
    

    Unfortunately I got the same result. It seems that Snowboy is the issue. It just wont install in the process. When I try the next command in the process I get this result.

    cd ~/MagicMirror/modules/MMM-Hotword/node_modules/snowboy
    

    I get the reply

    pi@raspberrypi:~ $ cd ~/MagicMirror/modules/MMM-Hotword/node_modules/snowboy
    bash: cd: /home/pi/MagicMirror/modules/MMM-Hotword/node_modules/snowboy: No such file or directory
    
    

    I’ve been at this since last weekend. It’s fun , but frustrating. Any other help would be awesome.

    Thanks!


  • Module Developer

    @cjdzombie

    pi@raspberrypi:~/MagicMirror/modules/MMM-Hotword $ npm install nan
    and then
    pi@raspberrypi:~/MagicMirror/modules/MMM-Hotword $ npm install
    Unfortunately I got the same result.

    Same result? Your prior issue Error: Cannot find module 'nan' should be solved by npm install nan. If not so, that is an issue of another level. It means your npm is not valid. So check again same result.


  • Module Developer

    @cjdzombie
    You can contact me with mail : eouia0819@gmail.com or Telegram: @eouia for the details.



  • @Sean i nicely use assistantmk2 with Hotword and i noticed that if i trigger assistant with hotword and for some reason get “conversation error” then hotword stops triggering but assistant works fine if i press the icon with the mouse.I have to restart MM to get hotword working again.Its not happening all the time but 1 maybe 2 times in the day.Any advice?


  • Module Developer

    @costascontis
    I need error logs and configurations for details.



  • @cjdzombie i just installed MMM-Hotword, and had the errors documented in the install.

    I followed the steps exactly, cutting and pasting, and those issues were resolved… MMM-Hotword works perfectly now