MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Python Cryptography help needed please



  • Hello… is there any python experts that could point me towards getting 18.1 installed… it’s on Linux Mint 18.3 - my daughters pc that I put linux on a while back, and not played with for a while.

    I followed a guide to install through terminal, and I will post the results for you to see if you can see what I have possibly done wrong, and what I need to enter in order to get the proper updated version.

    stacey@stacey-System-Name ~ $ pip install cryptography
    The program 'pip' is currently not installed. You can install it by typing:
    sudo apt install python-pip
    stacey@stacey-System-Name ~ $ sudo apt install python-pip
    [sudo] password for stacey: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      python-pip-whl
    Recommended packages:
      build-essential python-all-dev python-setuptools python-wheel
    The following NEW packages will be installed
      python-pip python-pip-whl
    0 to upgrade, 2 to newly install, 0 to remove and 592 not to upgrade.
    Need to get 1,255 kB of archives.
    After this operation, 1,854 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/universe i386 python-pip-whl all 8.1.1-2ubuntu0.4 [1,110 kB]
    Get:2 http://archive.ubuntu.com/ubuntu xenial-updates/universe i386 python-pip all 8.1.1-2ubuntu0.4 [144 kB]
    Fetched 1,255 kB in 0s (3,031 kB/s)
    Selecting previously unselected package python-pip-whl.
    (Reading database ... 237946 files and directories currently installed.)
    Preparing to unpack .../python-pip-whl_8.1.1-2ubuntu0.4_all.deb ...
    Unpacking python-pip-whl (8.1.1-2ubuntu0.4) ...
    Selecting previously unselected package python-pip.
    Preparing to unpack .../python-pip_8.1.1-2ubuntu0.4_all.deb ...
    Unpacking python-pip (8.1.1-2ubuntu0.4) ...
    Processing triggers for man-db (2.7.5-1) ...
    Setting up python-pip-whl (8.1.1-2ubuntu0.4) ...
    Setting up python-pip (8.1.1-2ubuntu0.4) ...
    stacey@stacey-System-Name ~ $ pip install cryptography
    Collecting cryptography
      Downloading https://files.pythonhosted.org/packages/8a/5d/be750bb858cfda0be7bcad88ef13acd0cb2f88a7490f361c0c814cb55dcd/cryptography-2.3.1-cp27-cp27mu-manylinux1_i686.whl (1.9MB)
        100% |████████████████████████████████| 1.9MB 190kB/s 
    Collecting enum34; python_version < "3" (from cryptography)
      Downloading https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
    Collecting asn1crypto>=0.21.0 (from cryptography)
      Downloading https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl (101kB)
        100% |████████████████████████████████| 102kB 1.3MB/s 
    Collecting cffi!=1.11.3,>=1.7 (from cryptography)
      Downloading https://files.pythonhosted.org/packages/7f/14/b0197bae7525d83ccb4cad3ad84b55e4ed8979b06fc884f81a26fefe8071/cffi-1.11.5-cp27-cp27mu-manylinux1_i686.whl (385kB)
        100% |████████████████████████████████| 389kB 765kB/s 
    Collecting idna>=2.1 (from cryptography)
      Downloading https://files.pythonhosted.org/packages/4b/2a/0276479a4b3caeb8a8c1af2f8e4355746a97fab05a372e4a2c6a6b876165/idna-2.7-py2.py3-none-any.whl (58kB)
        100% |████████████████████████████████| 61kB 879kB/s 
    Collecting six>=1.4.1 (from cryptography)
      Downloading https://files.pythonhosted.org/packages/67/4b/141a581104b1f6397bfa78ac9d43d8ad29a7ca43ea90a2d863fe3056e86a/six-1.11.0-py2.py3-none-any.whl
    Collecting ipaddress; python_version < "3" (from cryptography)
      Downloading https://files.pythonhosted.org/packages/fc/d0/7fc3a811e011d4b388be48a0e381db8d990042df54aa4ef4599a31d39853/ipaddress-1.0.22-py2.py3-none-any.whl
    Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography)
      Downloading https://files.pythonhosted.org/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz (158kB)
        100% |████████████████████████████████| 163kB 1.1MB/s 
        Complete output from command python setup.py egg_info:
        Traceback (most recent call last):
          File "", line 1, in 
        ImportError: No module named setuptools
        
        ----------------------------------------
    Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-y3X1EP/pycparser/
    You are using pip version 8.1.1, however version 18.1 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    stacey@stacey-System-Name ~ $ pip install --upgrade pip
    Collecting pip
      Downloading https://files.pythonhosted.org/packages/c2/d7/90f34cb0d83a6c5631cf71dfe64cc1054598c843a92b400e55675cc2ac37/pip-18.1-py2.py3-none-any.whl (1.3MB)
        100% |████████████████████████████████| 1.3MB 262kB/s 
    Installing collected packages: pip
    Successfully installed pip-8.1.1
    You are using pip version 8.1.1, however version 18.1 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    stacey@stacey-System-Name ~ $ pip install --upgrade pip
    Traceback (most recent call last):
      File "/usr/bin/pip", line 9, in 
        from pip import main
    ImportError: cannot import name main
    stacey@stacey-System-Name ~ $ 'pip install --upgrade pip' 
    pip install --upgrade pip: command not found
    stacey@stacey-System-Name ~ $ 
    

    ‘’’



  • ----- I know I entered again at the very end ---- 'pip install --upgrade pip’ — using quotes, this was a C&P error, but it still wont work even without those mistaken quotes.