MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.

MMM-Facial-Recognition-OCV3 error at

  • @nischi

    Sorry, i just saw your replies…

    I am working on a Mac via VNC viewer and Terminal, all the software is installed on the Rpi 3 b+ directly though. I followed the installation steps on the page thoroughly, so I don’t know what could have gone wrong.

    I did since then install MotionEye for another aspect I want to add to the mirror and I notice that it adds “boxes” around detected movement - I don’t think it does this normally, but rather is related to the OCV install; only the recognition wouldn’t work anyhow due to the fact its not been “trained” who’s who.

    Please let me know how your new version goes. I am desperate to get this facial recognition finally working on my mirror.

  • @SdeGeata

    Hey @Nischi! I got it going!!!

    Two things fixed it. The first was a directory error that was preventing capture. Fixed with:


    from config import ToolsConfig -> from .config import ToolsConfig

    the second was an outdated PIP that wasn’t getting updated without SUDO that was giving me the error on Training.

    sudo pip install future --upgrade

    Both are fixed now and XML is generated. Next on to configuration. Thanks to all for your help.

  • @SdeGeata
    Cool that it works. I’m nearly done with my new module now. Will inform you if you can try out. And the good thing. The classes config from your old module will be compatible.

  • @nischi

    Cool. Lemme know.

  • @SdeGeata
    Now it’s finally done and tested on my own Magic Mirror with the PiCamera. Let me know if you have any issues and need some help.

  • That’s great news! I’m gonna install it today and give it a whirl. I’ve spent too much time swearing about the other one not working like it should. I’ll let you know how it goes.

  • Well, since my post yesterday, I’ve not got past building Open CV 4. Hangs at 20%, or 73%, or 100% and eventually freezes. it never finishes the compilation.

    I completely wiped my SD card and did a fresh install of Rasbian - just to see if that would make a difference. So far, no go. I’m losing patience with this thing. It’s been well over a week that i’ve been fiddling around with various face recognition modules that kinda half work. i am anxious to try yours - i just can’t get past the Open CV bugs on install.

    What should I do???

  • @SdeGeata
    Sorry to hear that you have some issue to install OpenCV. Which Hardware do you have? On my Raspi 3+ it works fine, first run and all compiled.

    Whats really important is that you extend your Swap, otherwise you will have some issues like you described.

    Did you go through this documentation?

    sudo nano /etc/dphys-swapfile
    # set size to absolute value, leaving empty (default) then uses computed value
    #   you most likely don't want this, unless you have an special disk situation
    sudo /etc/init.d/dphys-swapfile stop
    sudo /etc/init.d/dphys-swapfile start

    Note: Increasing swap size is a great way to burn out your Raspberry Pi microSD card. Flash-based storage have limited number of writes you can perform until the card is essentially unable to hold the 1’s and 0’s anymore. We’ll only be enabling large swap for a short period of time, so it’s not a big deal.

  • @nischi

    Hello again;

    I finally got Open CV 4 installed successfully, I am re-installing my mirror modules now.

    I did extend the swap to 2048, and that failed making -j4 and -j1. Finally I boosted the swap to 5000, it still failed on -j1, but it finally worked on -j2… go figure.

    I was pretty tired of f**cking around trying to get that to install, it was pretty discouraging.

    Thanks for your help and I will let you know how it goes once I get your new module installed.

  • @SdeGeata
    Sorry to hear that you had such problems to install OpenCV. Hope it works now and let me know how it works.