MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Not enough perfomrance for MMM-hello-mirror?



  • I´ve installed the module on my MagicMirror with Raspberry Pi2. After a relatively long time I can see “Ich dir zu Meister” on the display, but nothing happend when I say “Hallo Spiegel” or “Hallo magischer Spiegel”. The speaker work, a recording via microphone ist possible. Where´s my problem?


  • Module Developer

    @boesemani May you please show us your log, you can access it via pm2 log mm if you installed it with the auto install script.



  • @idoodler
    [TAILING] Tailing last 15 lines for [mm] process (change the value with --lines option)
    /home/pi/.pm2/logs/mm-error.log last 15 lines:
    0|mm | Please make sure you have the correct access rights
    0|mm | and the repository exists.
    0|mm |
    0|mm | Permission denied (publickey).
    0|mm | fatal: Could not read from remote repository.
    0|mm |
    0|mm | Please make sure you have the correct access rights
    0|mm | and the repository exists.
    0|mm |
    0|mm | Permission denied (publickey).
    0|mm | fatal: Could not read from remote repository.
    0|mm |
    0|mm | Please make sure you have the correct access rights
    0|mm | and the repository exists.
    0|mm |

    /home/pi/.pm2/logs/mm-out.log last 15 lines:
    0|mm | { topic: ‘/Wohnung/Buero/humidity’,
    0|mm | label: ‘Luftfeuchtigkeit’,
    0|mm | suffix: ‘%’,
    0|mm | decimals: 0,
    0|mm | sortOrder: 20,
    0|mm | maxAgeSeconds: 60 } ] }
    0|mm | MMM-MQTT: Starting client for: { serverKey: ‘192.168.178.16:1883’,
    0|mm | address: ‘192.168.178.16’,
    0|mm | port: ‘1883’,
    0|mm | options: { username: ‘user’, password: ‘password’ },
    0|mm | topics: [ ‘/Wohnung/Buero/temp’, ‘/Wohnung/Buero/humidity’ ] }
    0|mm | MMM-MQTT: Connecting to mqtt://192.168.178.16
    0|mm | Create new news fetcher for url: http://www.tagesschau.de/xml/rss2 - Interval: 300000
    0|mm | MMM-MQTT connected to mqtt://192.168.178.16
    0|mm | MMM-MQTT: subscribing to /Wohnung/Buero/temp,/Wohnung/Buero/humidity
    Could this be helpful?


  • Module Developer

    @boesemani The only suspicion thing I can see is the Permission denied (publickey) message, but I don’t think it is related to your problem.

    You can install MMM-SystemStats and check your RAM and CPU load that way.